hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fab wol <darkwoll...@gmail.com>
Subject NullPointerException on Sample Tables / CDH 4.4
Date Fri, 11 Oct 2013 07:35:15 GMT
hey everyone,

I've got supplied with a decent ten node CDH 4.4 cluster, only 7 days old,
and someone tried some HBase stuff on it. I wanted to apply my (on another
cluster working) workflow's to that cluster (consisting of HiveQL Scripts
and Oozie Workflows) but unfortunately i the following issue: When trying
to drop some select statement on any table (sample tables or tables
regarding my workflow) i get the following error stack (from beeswax and
from Hive CLI):

java.io.IOException:
org.apache.hadoop.ipc.RemoteException(java.lang.NullPointerException):
java.lang.NullPointerException
	at org.apache.hadoop.hdfs.server.blockmanagement.DatanodeManager.sortLocatedBlocks(DatanodeManager.java:334)
	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.getBlockLocations(FSNamesystem.java:1245)
	at org.apache.hadoop.hdfs.server.namenode.NameNodeRpcServer.getBlockLocations(NameNodeRpcServer.java:413)
	at org.apache.hadoop.hdfs.protocolPB.ClientNamenodeProtocolServerSideTranslatorPB.getBlockLocations(ClientNamenodeProtocolServerSideTranslatorPB.java:172)
	at org.apache.hadoop.hdfs.protocol.proto.ClientNamenodeProtocolProtos$ClientNamenodeProtocol$2.callBlockingMethod(ClientNamenodeProtocolProtos.java:44938)
	at org.apache.hadoop.ipc.ProtobufRpcEngine$Server$ProtoBufRpcInvoker.call(ProtobufRpcEngine.java:453)
	at org.apache.hadoop.ipc.RPC$Server.call(RPC.java:1002)
	at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:1751)
	at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:1747)
	at java.security.AccessController.doPrivileged(Native Method)
	at javax.security.auth.Subject.doAs(Subject.java:396)
	at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1408)
	at org.apache.hadoop.ipc.Server$Handler.run(Server.java:1745)


I tried already setting up a new table (blank) and inserting some
dummy data, but the error keeps the same. Some connection between HDFS
and Hive regarind block information seems to be broken. Any idea how
to fix this or where the configuration is to get rid of this or what
other things we should check?

Cheers

Fabian

Mime
View raw message