hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wesley dias <wesleyd...@outlook.com>
Subject RE: Building hive package against latest hadoop-3.0.0-SNAPSHOT
Date Sat, 21 Sep 2013 11:43:22 GMT
I did read on the hive documentation that we could build the package using -Dhadoop.version="<your-hadoop-version>"
option with ant package command.
However, it is also mentioned in the documentation that by default, Hadoop tarballs are pulled
from http://mirror.facebook.net/facebook/hive-deps. So if the hadoop-3.0.0-SNAPSHOT tarball
is not present on that location(which it is not). The package may not build correctly. 
This is my understanding, please correct me if I am wrong.
 
Regards,
 
Wesley 
Date: Sat, 21 Sep 2013 21:10:35 +1000
Subject: Re: Building hive package against latest hadoop-3.0.0-SNAPSHOT
From: jagatsingh@gmail.com
To: user@hive.apache.org

Its defined in build.properties
You can try changing there and build.
http://svn.apache.org/viewvc/hive/trunk/build.properties?revision=1521520&view=markup
On 21/09/2013 8:19 PM, "wesley dias" <wesleydias@outlook.com> wrote:






Hello Everyone,
 
I am new to hive and I had a query related to building the Hive package from source. Is it
possible to build a hive distribution against the latest hadoop source which is hadoop-3.0.0-SNAPSHOT?

 
Currently, when I create a hive distribution and try running it against the latest hadoop
package created by me It give a build not supported message. So just wanted to check it there
was a way to build Hive package from ant using latest hadoop version present in source.

 
Regards,
 
Wesley
            
 		 	   		  
 		 	   		  
Mime
View raw message