hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manickam P <manicka...@outlook.com>
Subject RE: Hive Query Issue
Date Tue, 06 Aug 2013 11:10:21 GMT
Hi,
Thanks for your reply. I have a small test table which has around 10 records. when i run select
* from table.. it launched a job and that got completed successfully. When i run the same
query in my actual table no job got initiated. it got struck. I did not get any error in my
task tracker also. All my data nodes are up and running. 
I don't have any clue here.

Thanks,
Manickam P
Date: Tue, 6 Aug 2013 16:24:38 +0530
Subject: Re: Hive Query Issue
From: nitinpawar432@gmail.com
To: user@hive.apache.org

when you run select * from table .. it does not launch a mapreduce job, 
where are when you put some condition, it does need to process the data so it launches a mapreduce
job 

now when you start this query, go to your jobtracker page and see how many jobs are running.
Is it able to start your job? if not why ? that will tell you why its stuck 


On Tue, Aug 6, 2013 at 3:22 PM, Manickam P <manickam.p@outlook.com> wrote:




Hi,
If i run a hive query like "select * from table_name limit 10" it is working.
If i run query like "select column_name from table_name limit 10" it hangs. Total MapReduce
jobs = 1
Launching Job 1 out of 1Number of reduce tasks is set to 0 since there's no reduce operator
It just prints the above after that nothing happening in the hive shell. 
Can you pls help me on this.

Thanks,
Manickam P 		 	   		  



-- 
Nitin Pawar

 		 	   		  
Mime
View raw message