hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mohammad Tariq <donta...@gmail.com>
Subject Re: "show table" throwing strange error
Date Thu, 20 Jun 2013 02:04:11 GMT
That error is gone after I recreated hive-site.xml and restarted hive. But
now there seems to be some problem with metastore settings. It's not going
to mysql.

Anyways, thank you both for the help.

Warm Regards,
Tariq
cloudfront.blogspot.com


On Thu, Jun 20, 2013 at 7:29 AM, Mohammad Tariq <dontariq@gmail.com> wrote:

> Yes. It's up and running with all the required permissions.
>
> Warm Regards,
> Tariq
> cloudfront.blogspot.com
>
>
> On Thu, Jun 20, 2013 at 7:21 AM, Anurag Tangri <tangri.anurag@gmail.com>wrote:
>
>> Looks like you use MySQL.
>>
>> Can you check if your MySQL still up ?
>>
>> and permissions on your hive metastore db ?
>>
>> Sent from my iPhone
>>
>> On Jun 19, 2013, at 6:44 PM, Mohammad Tariq <dontariq@gmail.com> wrote:
>>
>> It actually seems to be ignoring hive-site.xml. No effect of the
>> properties set in hive-site.xml file.
>>
>> Warm Regards,
>> Tariq
>> cloudfront.blogspot.com
>>
>>
>> On Thu, Jun 20, 2013 at 7:12 AM, Mohammad Tariq <dontariq@gmail.com>wrote:
>>
>>> It looks OK to me,
>>>
>>> <configuration>
>>>
>>> <property>
>>>   <name>javax.jdo.option.ConnectionURL</name>
>>>   <value>jdbc:mysql://localhost:3306/hive?*createDatabaseIfNotExist*
>>> =true</value>
>>> </property>
>>>
>>> <property>
>>>   <name>javax.jdo.option.ConnectionDriverName</name>
>>>   <value>com.mysql.jdbc.Driver</value>
>>> </property>
>>>
>>> <property>
>>>   <name>javax.jdo.option.ConnectionUserName</name>
>>>   <value>apache</value>
>>> </property>
>>>
>>> <property>
>>>   <name>javax.jdo.option.ConnectionPassword</name>
>>>   <value>password</value>
>>> </property>
>>>
>>> <property>
>>>   <name>hive.metastore.local</name>
>>>   <value>true</value>
>>> </property>
>>>
>>> <property>
>>>     <name>hive.exec.scratchdir</name>
>>>     <value>/hadoop/hive-tmp</value>
>>>     <description>Scratch space for Hive jobs</description>
>>> </property>
>>>
>>> </configuration>
>>>
>>> Anything wrong here?
>>>
>>> Thank you.
>>>
>>> Warm Regards,
>>> Tariq
>>> cloudfront.blogspot.com
>>>
>>>
>>> On Thu, Jun 20, 2013 at 7:06 AM, Mapred Learn <mapred.learn@gmail.com>wrote:
>>>
>>>> Can you also check your hive site XML ?
>>>> Is it properly formatted and connection strings correct ?
>>>>
>>>> Sent from my iPhone
>>>>
>>>> On Jun 19, 2013, at 6:30 PM, Mohammad Tariq <dontariq@gmail.com> wrote:
>>>>
>>>> Hello Anurag,
>>>>
>>>>    Thank you for the quick response. Log files is full of such lines
>>>> along with a trace that says it is some parsing related issue. But the
>>>> strange thing is that here I can see *'\00' *but on the CLI it was
>>>> just *' '. *I am wondering what's with wrong with *show tables;*
>>>> *
>>>> *
>>>> line 1:79 character '\00' not supported here
>>>> line 1:80 character '\00' not supported here
>>>>
>>>> at
>>>> org.apache.hadoop.hive.ql.parse.ParseDriver.parse(ParseDriver.java:446)
>>>>  at org.apache.hadoop.hive.ql.Driver.compile(Driver.java:416)
>>>> at org.apache.hadoop.hive.ql.Driver.compile(Driver.java:336)
>>>>  at org.apache.hadoop.hive.ql.Driver.run(Driver.java:909)
>>>> at
>>>> org.apache.hadoop.hive.cli.CliDriver.processLocalCmd(CliDriver.java:258)
>>>>  at org.apache.hadoop.hive.cli.CliDriver.processCmd(CliDriver.java:215)
>>>> at org.apache.hadoop.hive.cli.CliDriver.processLine(CliDriver.java:406)
>>>>  at org.apache.hadoop.hive.cli.CliDriver.run(CliDriver.java:689)
>>>> at org.apache.hadoop.hive.cli.CliDriver.main(CliDriver.java:557)
>>>>  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>>> at
>>>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
>>>>  at
>>>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>>>> at java.lang.reflect.Method.invoke(Method.java:601)
>>>>  at org.apache.hadoop.util.RunJar.main(RunJar.java:156)
>>>>
>>>> Thanks again.
>>>>
>>>> Warm Regards,
>>>> Tariq
>>>> cloudfront.blogspot.com
>>>>
>>>>
>>>> On Thu, Jun 20, 2013 at 6:53 AM, Anurag Tangri <tangri.anurag@gmail.com
>>>> > wrote:
>>>>
>>>>> Did you check in your hive query log under /tmp to see if it says
>>>>> something in the log ?
>>>>>
>>>>>
>>>>> Sent from my iPhone
>>>>>
>>>>> On Jun 19, 2013, at 5:53 PM, Mohammad Tariq <dontariq@gmail.com>
>>>>> wrote:
>>>>>
>>>>> Hello list,
>>>>>
>>>>>          I have a hive(0.9.0) setup on my Ubuntu box running
>>>>> hadoop-1.0.4. Everything was going smooth till now. But today when I
issued
>>>>> *show tables* I got some strange error on the CLI. Here is the error
:
>>>>>
>>>>> hive> show tables;
>>>>> FAILED: Parse Error: line 1:0 character '' not supported here
>>>>> line 1:1 character '' not supported here
>>>>> line 1:2 character '' not supported here
>>>>> line 1:3 character '' not supported here
>>>>> line 1:4 character '' not supported here
>>>>> line 1:5 character '' not supported here
>>>>> line 1:6 character '' not supported here
>>>>> line 1:7 character '' not supported here
>>>>> line 1:8 character '' not supported here
>>>>> line 1:9 character '' not supported here
>>>>> line 1:10 character '' not supported here
>>>>> line 1:11 character '' not supported here
>>>>> line 1:12 character '' not supported here
>>>>> line 1:13 character '' not supported here
>>>>> line 1:14 character '' not supported here
>>>>> line 1:15 character '' not supported here
>>>>> line 1:16 character '' not supported here
>>>>> line 1:17 character '' not supported here
>>>>> line 1:18 character '' not supported here
>>>>> line 1:19 character '' not supported here
>>>>> line 1:20 character '' not supported here
>>>>> line 1:21 character '' not supported here
>>>>> line 1:22 character '' not supported here
>>>>> line 1:23 character '' not supported here
>>>>> line 1:24 character '' not supported here
>>>>> line 1:25 character '' not supported here
>>>>> line 1:26 character '' not supported here
>>>>> line 1:27 character '' not supported here
>>>>> line 1:28 character '' not supported here
>>>>> line 1:29 character '' not supported here
>>>>> line 1:30 character '' not supported here
>>>>> line 1:31 character '' not supported here
>>>>> line 1:32 character '' not supported here
>>>>> line 1:33 character '' not supported here
>>>>> line 1:34 character '' not supported here
>>>>> line 1:35 character '' not supported here
>>>>> line 1:36 character '' not supported here
>>>>> line 1:37 character '' not supported here
>>>>> line 1:38 character '' not supported here
>>>>> line 1:39 character '' not supported here
>>>>> line 1:40 character '' not supported here
>>>>> line 1:41 character '' not supported here
>>>>> line 1:42 character '' not supported here
>>>>> line 1:43 character '' not supported here
>>>>> line 1:44 character '' not supported here
>>>>> line 1:45 character '' not supported here
>>>>> line 1:46 character '' not supported here
>>>>> line 1:47 character '' not supported here
>>>>> line 1:48 character '' not supported here
>>>>> line 1:49 character '' not supported here
>>>>> line 1:50 character '' not supported here
>>>>> line 1:51 character '' not supported here
>>>>> line 1:52 character '' not supported here
>>>>> line 1:53 character '' not supported here
>>>>> line 1:54 character '' not supported here
>>>>> line 1:55 character '' not supported here
>>>>> line 1:56 character '' not supported here
>>>>> line 1:57 character '' not supported here
>>>>> line 1:58 character '' not supported here
>>>>> line 1:59 character '' not supported here
>>>>> line 1:60 character '' not supported here
>>>>> line 1:61 character '' not supported here
>>>>> line 1:62 character '' not supported here
>>>>> line 1:63 character '' not supported here
>>>>> line 1:64 character '' not supported here
>>>>> line 1:65 character '' not supported here
>>>>> line 1:66 character '' not supported here
>>>>> line 1:67 character '' not supported here
>>>>> line 1:68 character '' not supported here
>>>>> line 1:69 character '' not supported here
>>>>> line 1:70 character '' not supported here
>>>>> line 1:71 character '' not supported here
>>>>> line 1:72 character '' not supported here
>>>>> line 1:73 character '' not supported here
>>>>> line 1:74 character '' not supported here
>>>>> line 1:75 character '' not supported here
>>>>> line 1:76 character '' not supported here
>>>>> line 1:77 character '' not supported here
>>>>> line 1:78 character '' not supported here
>>>>> line 1:79 character '' not supported here
>>>>> .
>>>>> .
>>>>> .
>>>>> .
>>>>> .
>>>>> .
>>>>> line 1:378 character '' not supported here
>>>>> line 1:379 character '' not supported here
>>>>> line 1:380 character '' not supported here
>>>>> line 1:381 character '' not supported here
>>>>>
>>>>> Strangely other queries like *select foo from pokes where bar =
>>>>> 'tariq';* are working fine. Tried to search over the net but could
>>>>> not find anything useful.Need some help.
>>>>>
>>>>> Thank you so much for your time.
>>>>>
>>>>> Warm Regards,
>>>>> Tariq
>>>>> cloudfront.blogspot.com
>>>>>
>>>>>
>>>>
>>>
>>
>

Mime
View raw message