hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zheng, Kai" <kai.zh...@intel.com>
Subject RE: Hive over HBase Integration Issue
Date Mon, 18 Feb 2013 02:24:52 GMT
Hi Harsh J,

Thanks for your replying. 
It looks good to me to place the client-sided hbase-site.xml in the same directory as hive-site.xml.

I already tried this approach before but didn't work. I will investigate this way wondering
if there're some gaps here or possibly 
It was just caused due to my environment (like Hive or Hbase version).

Regards,
Kai

-----Original Message-----
From: Harsh J [mailto:harsh@cloudera.com] 
Sent: Sunday, February 17, 2013 10:10 PM
To: hive request
Cc: user@hbase.apache.org; Andrew Purtell <apurtell@apache.org> (apurtell@apache.org)
Subject: Re: Hive over HBase Integration Issue

You could replicate the configs or place the client-sided hbase-site.xml in the same directory
as hive-site.xml for it to get picked up via the classpath by HBase centric classes.

On Sun, Feb 17, 2013 at 2:41 PM, Zheng, Kai <kai.zheng@intel.com> wrote:
> Hi all,
>
>
>
> In Hive over HBase case, how to configure and  get Hive as HBase 
> client to reference hbase-site.xml (for example the one in /etc/hbase/conf)?
>
>
>
> In this case it's necessary to do that since there're some specific 
> and important client configurations for all HBase clients including 
> Hive, and such
>
> configuration shouldn't be replicated/copied into hive-site.xml right.
>
>
>
> Thanks for your info.
>
>
>
> Regards,
>
> Kai
>
>



--
Harsh J

Mime
View raw message