hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From MiaoMiao <liy...@gmail.com>
Subject Re: Error in semantic analysis: Unable to fetch table
Date Fri, 19 Oct 2012 05:15:27 GMT
What php, you are using exec('hive -S -e "select * from some_table"')
or something like that in php?

On Fri, Oct 19, 2012 at 4:46 AM, Keith Wiley <kwiley@keithwiley.com> wrote:
> If I run a select command on the command line with -e it works.  If I run the same command
inside hive (without -e) it still works...but if I exec it with a -e from php (so obviously
the apache user), I get "Error in semantic analysis: Unable to fetch table [tablename]". 
Bear in mind that this overall system worked perfectly for weeks.  I haven't modified the
code or anything.  What did change was I had to reinstall hadoop and hive and I'm sure some
configuration parameter is not correct now.  I found some Google references to this error
but no clear-but solutions.
>
> What does this error mean and how do I fix it?
>
> Thanks.
>
> ________________________________________________________________________________
> Keith Wiley     kwiley@keithwiley.com     keithwiley.com    music.keithwiley.com
>
> "The easy confidence with which I know another man's religion is folly teaches
> me to suspect that my own is also."
>                                            --  Mark Twain
> ________________________________________________________________________________
>

Mime
View raw message