hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshi, Rekha" <Rekha_Jo...@intuit.com>
Subject Re: Issue while using hive 0.9
Date Tue, 18 Sep 2012 09:12:07 GMT
Yes, it and all (hive-lib and hadoop jars) should be seen in class path.Please set.

And if antlr 3.0.1 does not work, you will have to checkout source to be able to build it
with new antlr, otherwise compile and runtime would clash.
However I agree today there was some issue with hive trunk build, but you can always choose
to take few days older build in such cases using svn co –r <release no>
svn co -r 1387000 http://svn.apache.org/repos/asf/hive/trunk hive

I did tried with latest (r,1387047) now, and the build seems to be happening fine.

Thanks
Rekha

From: Sarath <sarathchandra.josyam@algofusiontech.com<mailto:sarathchandra.josyam@algofusiontech.com>>
Reply-To: <user@hive.apache.org<mailto:user@hive.apache.org>>
Date: Tue, 18 Sep 2012 11:21:57 +0530
To: <user@hive.apache.org<mailto:user@hive.apache.org>>
Subject: Re: Issue while using hive 0.9

No I don't see any antlr jars in the output. Infact not even the default version that exists
in the hive lib folder.
Do I need to explicitly mention in the classpath?

On Tuesday 18 September 2012 11:16 AM, Ashutosh Chauhan wrote:
Do
ps aux | grep hive
n check the classpath of hive process. See if you can spot antlr jar versions in it.

On Mon, Sep 17, 2012 at 10:40 PM, Sarath <sarathchandra.josyam@algofusiontech.com<mailto:sarathchandra.josyam@algofusiontech.com>>
wrote:
Thanks for the quick reply. Tried it. But same issue.

Pointed system to JDK 1.6 (update 32).
Changed hadoop conf to use this JDK. "java -version" prints the 1.6 version.
Replaced antlr JAR with the same version as it came in hive binary (3.0.1).

Anything else I have to do? Do I need to make any changes in hive->conf folder?


On Tuesday 18 September 2012 10:35 AM, Ashutosh Chauhan wrote:
Only thing which is different then usual setups is jdk1.7 Is it possible for you to test with
jdk1.6 ?

Ashutosh
On Mon, Sep 17, 2012 at 10:02 PM, Sarath Chandra <sarathchandra.josyam@algofusiontech.com<mailto:sarathchandra.josyam@algofusiontech.com>>
wrote:
@Ashutosh
I haven't built my hive from sources. I just downloaded the binaries from the site. The downloaded
tar has come with 3.0.1 version of antlr. I didn't do any changes. Just set the environment
variables and invoked hive and got this error. I checked out sources and tried to build hive
as directed in hive wiki. But the build failed.

@Rekha
Downloaded 3.4.1 version from the site mentioned and tried again. No luck. Same issue.

Just wondering now, how is it working for others out there. What am I missing? Am I doing
something wrong? Is this right combination - jdk 1.7 / hadoop 1.0.3 / hive 0.9.0?

Regards,
Sarath.


On Tue, Sep 18, 2012 at 9:00 AM, Joshi, Rekha <Rekha_Joshi@intuit.com<mailto:Rekha_Joshi@intuit.com>>
wrote:
Hi Sarath,

Sorry for delay – I don't see this mail folder all the time.

Anyhow do try with exactly antler 3.4.1 – available at http://www.antlr.org/wiki/display/ANTLR3/ANTLR+3+Wiki+Home

Even antler 3.0.1 might work.

Thanks
Rekha

From: Sarath <sarathchandra.josyam@algofusiontech.com<mailto:sarathchandra.josyam@algofusiontech.com>>
Reply-To: <user@hive.apache.org<mailto:user@hive.apache.org>>
Date: Mon, 17 Sep 2012 17:10:01 +0530
To: <user@hive.apache.org<mailto:user@hive.apache.org>>
Subject: Re: Issue while using hive 0.9

>From ANTLR site downloaded the latest JAR -> antlr-3.4-complete.jar.
Copied this to lib folder and tried again. Same issue persists.

Thanks,
Sarath.

On Monday 17 September 2012 04:42 PM, Joshi, Rekha wrote:
Try with antlr 3.4.1 jar?

Thanks
Rekha

From: Sarath <sarathchandra.josyam@algofusiontech.com<mailto:sarathchandra.josyam@algofusiontech.com>>
Reply-To: <user@hive.apache.org<mailto:user@hive.apache.org>>
Date: Mon, 17 Sep 2012 16:24:02 +0530
To: <user@hive.apache.org<mailto:user@hive.apache.org>>
Subject: Issue while using hive 0.9

Hi,

I'm new to hive.

As first step downloaded version 0.9 and upacked it. Set the HIVE_HOME to the unpacked folder.
I already have hadoop 1.0.3 installed and its configuration is in classpath.

Then issued the hive command and got the hive prompt. After this whatever I try to execute,
results in the below error -
Exception in thread "main" java.lang.NoSuchFieldError: type
    at org.apache.hadoop.hive.ql.parse.HiveLexer.mKW_CREATE(HiveLexer.java:1602)
    at org.apache.hadoop.hive.ql.parse.HiveLexer.mTokens(HiveLexer.java:6380)
    at org.antlr.runtime.Lexer.nextToken(Lexer.java:89)
    at org.antlr.runtime.BufferedTokenStream.fetch(BufferedTokenStream.java:133)
    at org.antlr.runtime.BufferedTokenStream.sync(BufferedTokenStream.java:127)
    at org.antlr.runtime.CommonTokenStream.setup(CommonTokenStream.java:132)
    at org.antlr.runtime.CommonTokenStream.LT<http://org.antlr.runtime.CommonTokenStream.LT>(CommonTokenStream.java:91)
    at org.apache.hadoop.hive.ql.parse.HiveParser.statement(HiveParser.java:547)
    at org.apache.hadoop.hive.ql.parse.ParseDriver.parse(ParseDriver.java:438)
    at org.apache.hadoop.hive.ql.Driver.compile(Driver.java:416)
    at org.apache.hadoop.hive.ql.Driver.compile(Driver.java:336)
    at org.apache.hadoop.hive.ql.Driver.run(Driver.java:909)
    at org.apache.hadoop.hive.cli.CliDriver.processLocalCmd(CliDriver.java:258)
    at org.apache.hadoop.hive.cli.CliDriver.processCmd(CliDriver.java:215)
    at org.apache.hadoop.hive.cli.CliDriver.processLine(CliDriver.java:406)
    at org.apache.hadoop.hive.cli.CliDriver.run(CliDriver.java:689)
    at org.apache.hadoop.hive.cli.CliDriver.main(CliDriver.java:557)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:601)
    at org.apache.hadoop.util.RunJar.main(RunJar.java:156)

Googled and found several posts with the same issue. Every where it says that issue is with
version of antlr.jar.
But I find that antlr.jar is already with correct version inside hive's lib directory and
I don't think there's any other antlr.jar in my classpath.

1. What is going wrong?
2. Where and what else to be checked?
3. How to resolve and start using Hive?

Please guide me.

Regards,
Sarath.






Mime
View raw message