hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshi, Rekha" <>
Subject Re: Issue while using hive 0.9
Date Tue, 18 Sep 2012 03:30:46 GMT
Hi Sarath,

Sorry for delay – I don't see this mail folder all the time.

Anyhow do try with exactly antler 3.4.1 – available at

Even antler 3.0.1 might work.


From: Sarath <<>>
Reply-To: <<>>
Date: Mon, 17 Sep 2012 17:10:01 +0530
To: <<>>
Subject: Re: Issue while using hive 0.9

>From ANTLR site downloaded the latest JAR -> antlr-3.4-complete.jar.
Copied this to lib folder and tried again. Same issue persists.


On Monday 17 September 2012 04:42 PM, Joshi, Rekha wrote:
Try with antlr 3.4.1 jar?


From: Sarath <<>>
Reply-To: <<>>
Date: Mon, 17 Sep 2012 16:24:02 +0530
To: <<>>
Subject: Issue while using hive 0.9


I'm new to hive.

As first step downloaded version 0.9 and upacked it. Set the HIVE_HOME to the unpacked folder.
I already have hadoop 1.0.3 installed and its configuration is in classpath.

Then issued the hive command and got the hive prompt. After this whatever I try to execute,
results in the below error -
Exception in thread "main" java.lang.NoSuchFieldError: type
    at org.apache.hadoop.hive.ql.parse.HiveLexer.mKW_CREATE(
    at org.apache.hadoop.hive.ql.parse.HiveLexer.mTokens(
    at org.antlr.runtime.Lexer.nextToken(
    at org.antlr.runtime.BufferedTokenStream.fetch(
    at org.antlr.runtime.BufferedTokenStream.sync(
    at org.antlr.runtime.CommonTokenStream.setup(
    at org.antlr.runtime.CommonTokenStream.LT(
    at org.apache.hadoop.hive.ql.parse.HiveParser.statement(
    at org.apache.hadoop.hive.ql.parse.ParseDriver.parse(
    at org.apache.hadoop.hive.ql.Driver.compile(
    at org.apache.hadoop.hive.ql.Driver.compile(
    at org.apache.hadoop.hive.cli.CliDriver.processLocalCmd(
    at org.apache.hadoop.hive.cli.CliDriver.processCmd(
    at org.apache.hadoop.hive.cli.CliDriver.processLine(
    at org.apache.hadoop.hive.cli.CliDriver.main(
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    at java.lang.reflect.Method.invoke(
    at org.apache.hadoop.util.RunJar.main(

Googled and found several posts with the same issue. Every where it says that issue is with
version of antlr.jar.
But I find that antlr.jar is already with correct version inside hive's lib directory and
I don't think there's any other antlr.jar in my classpath.

1. What is going wrong?
2. Where and what else to be checked?
3. How to resolve and start using Hive?

Please guide me.


View raw message