hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rohithsharma <rohithsharm...@huawei.com>
Subject RE: FAILED: Error in metadata
Date Tue, 11 Sep 2012 09:05:18 GMT
Hi

 

Exception trace clearly indicates that hive is pointing to default
configurations.

Make sure your editing hive-site.xml is loaded by hive server. For verifying
whether correct configurations are loaded, you enable DEBUG logs.

There you can see the loaded configurations. Verify your configurations with
loaded configuration (In hive.log). 

 

Regards

rohith Sharma k s

 

From: Ravindra [mailto:ravindra.bajpai@gmail.com] 
Sent: Monday, September 10, 2012 11:49 AM
To: user@hive.apache.org
Subject: Re: FAILED: Error in metadata

 

I am new to Hive, Still 2 cents -

1. Do you have metastore_db already created, I don't see this name in your
hive-site (you have "try").
2. Hope you have your database client driver jar copied in the hive
classpath.

--
Ravi.
''We do not inherit the earth from our ancestors, we borrow it from our
children.'' PROTECT IT !




On Mon, Sep 10, 2012 at 10:40 AM, Hongjie Guo <hongjie.is@gmail.com> wrote:

check your mysql first,  if you can see some tables like "TBLS","COLUMNS",
the mysql should  work fine.
otherwise you should check your configuration about the hive-site.xml

 

2012/9/10 yogesh dhari <yogeshdhari@live.com>

Helli Bejoy,

I have restarted the hive and all cluster again but still the same issue.

Please help me out


Thanks & regards
Yogesh Kumar

  _____  

Date: Sun, 9 Sep 2012 02:21:47 -0700
From: bejoy_ks@yahoo.com
Subject: Re: FAILED: Error in metadata
To: user@hive.apache.org

 

Hi Yogesh

 

It looks like hive is still on the derby db . Can you restart your hive
instances after updating the hive-site.xml. Also please make sure that you
are modifying the right copy of the file.

 

Regards,

Bejoy KS

 

  _____  

From: yogesh dhari <yogeshdhari@live.com>
To: hive request <user@hive.apache.org> 
Sent: Sunday, September 9, 2012 2:21 PM
Subject: FAILED: Error in metadata

 

Hi all,

 my hive-site.xml is


<property>
        <name>javax.jdo.option.ConnectionURL</name>
 
<value>jdbc:mysql://127.0.0.1:3306/try?createDatabaseIfNotExist=true</value>
    </property>
    
    <property>
        <name>javax.jdo.option.ConnectionDriverName</name>
        <value>com.mysql.jdbc.Driver</value>
    </property>
    
    <property>
        <name>javax.jdo.option.ConnectionUserName</name>
        <value>hadoop</value>
    </property>
    
    <property>
        <name>javax.jdo.option.ConnectionPassword</name>
        <value>hadoop</value>
    </property> 


and created a user in my sql.

 CREATE USER 'hadoop'@'localhost' IDENTIFIED BY 'hadoop'; 
GRANT ALL PRIVILEGES ON *.* TO 'hadoop' WITH GRANT OPTION;

Schema name is try, and connection name is Demo


When I run hive in single terminal then it runs fine but when i try to run
hive parallel on new terminal window it shows the error:


FAILED: Error in metadata: javax.jdo.JDOFatalDataStoreException: Failed to
start database 'metastore_db', see the next exception for details.
NestedThrowables:
java.sql.SQLException: Failed to start database 'metastore_db', see the next
exception for details.
FAILED: Execution Error, return code 1 from
org.apache.hadoop.hive.ql.exec.DDLTask


Please help and suggest
Yogesh Kumar



 

 

 


Mime
View raw message