hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bejoy KS" <bejoy...@yahoo.com>
Subject Re: Data Loaded but Select returns nothing!
Date Mon, 30 Jul 2012 12:14:41 GMT
Kuldeep

Couple of things I hoticed here are

Your table is bucketed, when you load data into a bucketed table you need to enable

hive.enforce.bucketing=true;

Bucketing needs a MR job so you need to load the non bucketed data into a normal table and
from that load to a bucketed table using 'Insert Overwrite'.

Then another quick nit
Your table is partitioned so you need to load your data into some partition but you have not
spefied a partition in Load.

Regards
Bejoy KS

Sent from handheld, please excuse typos.

-----Original Message-----
From: Kuldeep Chitrakar <kuldeep.chitrakar@synechron.com>
Date: Mon, 30 Jul 2012 06:58:33 
To: user@hive.apache.org<user@hive.apache.org>
Reply-To: user@hive.apache.org
Subject: Data Loaded but Select returns nothing!

Hi

I am trying to load a CSV file into HIve table.

Everything works fine but when a fire "select * from tablename" command. It does not retun
anything.

--Create Table

CREATE TABLE IF NOT EXISTS learn.crime_managed_native (
NoState String,
TypeofCrime String,
Crime String,
Year int,
Count int)
PARTITIONED BY (State String)
CLUSTERED BY (Crime) SORTED BY (Year ASC) INTO 8 BUCKETS
ROW FORMAT DELIMITED FIELDS TERMINATED BY ','
STORED AS TEXTFILE;

--Load Data

LOAD DATA LOCAL INPATH '/home/cloudera/CrimeHive.csv' INTO TABLE crime_managed_native;

What could be the possible issue.

Thanks,
Kuldeep




Mime
View raw message