hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <>
Subject HIVE table showing NULL
Date Fri, 06 Jul 2012 09:17:46 GMT
Hi all

I have created a table tich in Mysql, its structure is:

Num           Name
01               Yogesh

and imported it into HDFS by using sqoop's command

sqoop import --connect jdbc:mysql://localhost:3306/Demo --username sqoop1 --password SQOOP1
--table tich --target-dir /HADOOP/hadoop-0.20.2/tichh7

it imported successfully
I created a table in hive called ticchi as

create table tichhi ( num INT , Name STRING)

now I am trying to upload that table record from HDFS to hive table I used this command.

LOAD DATA INPATH 'hdfs://localhost:9000/HADOOP/hadoop-0.20.2/tichh7/part-m-00000' OVERWRITE
INTO TABLE tichhi ;

optput is

Loading data to table default.tichhi
Deleted hdfs://localhost:9000/user/hive/warehouse/tichhi
Time taken: 0.14 seconds

Then I looked the records into hive table using and found values NULL

hive> select * from tichhi;
Time taken: 0.051 seconds

please help me and suggest why is it so

Thanks & Regards
Yogesh Kumar

Please do not print this email unless it is absolutely necessary. 

The information contained in this electronic message and any attachments to this message are
intended for the exclusive use of the addressee(s) and may contain proprietary, confidential
or privileged information. If you are not the intended recipient, you should not disseminate,
distribute or copy this e-mail. Please notify the sender immediately and destroy all copies
of this message and any attachments. 

WARNING: Computer viruses can be transmitted via email. The recipient should check this email
and any attachments for the presence of viruses. The company accepts no liability for any
damage caused by any virus transmitted by this email.

View raw message