hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ruben de Vries <>
Subject RE: Hive-0.8.1 PHP Thrift client broken?
Date Mon, 18 Jun 2012 08:16:53 GMT
Going to bump this one since I hope to be able to contribute some (worth a bump :P)

-----Original Message-----
From: Ruben de Vries [] 
Sent: Friday, June 15, 2012 11:59 AM
Subject: Hive-0.8.1 PHP Thrift client broken?

Hey Guys,

I've been slamming my head into a wall before on this issue, but now that I'm a bit more familiar
with Hive and Thrift (I got the python version working) I figured I should try fixing the
problem or find out more about it to contribute some to the project too :)

The php thriftclient lib which comes with the hive-0.8.1 package is completely f*cked.
It has a couple of issues so far:
 - the php files in the packages directory are 1 level to deep (eg, /packages/metastore/metastore/*.php).
 - there's a constant called 'GLOBAL' but this is a reserved keyword ...
 - it crashes with an error (and patch) described here:

Now I figured I could just checkout all the code and see how the PHP code is generated from
the thrift code ...
But the 'share/fb303/if/fb303.thrift' is missing!
I found some information on this googleing but nothing that wasn't so outdated that it would

Could someone start by helping me with this missing dependency to generate the thrift libs
and then maybe I can see if I can fix some of the other issues myself :-) ?

View raw message