hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From alo alt <wget.n...@googlemail.com>
Subject Re: Parse Error with '-' in Hive
Date Thu, 31 May 2012 15:40:50 GMT
Hi,

try to use _ instead -
UA_Platform STRING,

and so on. 

- Alex 

--
Alexander Alten-Lorenz
http://mapredit.blogspot.com
German Hadoop LinkedIn Group: http://goo.gl/N8pCF

On May 31, 2012, at 5:35 PM, Alex Barrera wrote:

> Hi there,
> 
> I'm looking for help with the following error: I keep receiving an error
> 'Parse Error: line 40:4 cannot recognize input near '-' 'Platform' STRING
> column type. '
> 
> It looks to be a problem with my JSON deserializer OR Hive not recognizing
> the - in the field names. So far I've tried commenting it out with / and
> //, and tried wrapping single and double quotes around the field name.
> Nothing has worked so far.
> 
> My code looks like this:
> add jar s3://sa/hive-json-serde-0.3.jar;
> DROP TABLE IF EXISTS viewstream;
> CREATE EXTERNAL TABLE IF NOT EXISTS viewstream(
>     cl STRING,
>     pid STRING,
>     vp STRING,
>     ar STRING,
>     UArm STRING,
>     dc STRING,
>     host STRING,
>     Blocked STRING,
>     UA-Platform STRING,
>     UA-Browser STRING,
>     UA-Version STRING,
>     UA-Language STRING
> )
> 
> ROW FORMAT SERDE 'org.apache.hadoop.hive.contrib.serde2.JsonSerde'
>  LOCATION 'hdfs:///repo/viewstream/';
> 
> Anybody run into similar errors? I can't find anything on this problem
> online, strangely enough.
> 
> Thanks all,
> Alex


Mime
View raw message