hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chalcy Raja <Chalcy.R...@careerbuilder.com>
Subject Setting up dev environment for hive
Date Wed, 14 Mar 2012 18:54:05 GMT
I have issues in setting up development environment for hive.  So far, I just got the jar file
modified and worked and now trying to get it to svn, so I can contribute code back.

Any help is appreciated.

Here is what I am doing now,

Went to page,

https://cwiki.apache.org/Hive/howtocontribute.html and got the source code in hive-trunk by
running

svn checkout http://svn.apache.org/repos/asf/hive/trunk hive-trunk

Then went to how to set up Eclipse for hive development and followed instructions from


BUILD FAILED
C:\hive-trunk\build.xml:361: The following error occurred while executing this l
ine:
C:\hive-trunk\build.xml:105: The following error occurred while executing this l
ine:
C:\hive-trunk\odbc\build.xml:67: Execute failed: java.io.IOException: Cannot run
program "make" (in directory "C:\hive-trunk\odbc"): CreateProcess error=2, The
system cannot find the file specified

Proceeded,



https://cwiki.apache.org/Hive/gettingstarted-eclipsesetup.html and ran ant clean package eclipse-files

 and got the below error when executing.  Tried the next step cd metastore and then ant model-jar
and got


model-enhance:
     [echo] Project: metastore

BUILD FAILED
C:\Eclipse\workspace\HiveTrunk\metastore\build.xml:93: taskdef class org.datanu
leus.enhancer.tools.EnhancerTask cannot be found
Thanks,
Chalcy
Mime
View raw message