hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edward Capriolo <edlinuxg...@gmail.com>
Subject Re: hive install exception
Date Fri, 10 Feb 2012 13:26:05 GMT
Hive should support 0.20 you might try 0.20.2. Which I have been using for
a while.

On Thursday, February 9, 2012, hezhiqiang (Ransom) <
ransom.hezhiqiang@huawei.com> wrote:
> Hi all
>
>          Yesterday,I install hive 0.8.1 in hadoop 1.0.0 version ,it’s ok.
>
>          But today,I install hive 0.8.1 in HDFS 0.20.1,it thorws
exceptions when execute hive shell.
>
>
>
> Exception in thread "main" java.lang.NoSuchMethodError:
org.apache.hadoop.hive.cli.CliSessionState.setIsVerbose(Z)V
>
>         at
org.apache.hadoop.hive.cli.OptionsProcessor.process_stage2(OptionsProcessor.java:160)
>
>         at org.apache.hadoop.hive.cli.CliDriver.run(CliDriver.java:585)
>
>         at org.apache.hadoop.hive.cli.CliDriver.main(CliDriver.java:554)
>
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>
>         at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>
>         at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>
>         at java.lang.reflect.Method.invoke(Method.java:597)
>
>         at org.apache.hadoop.util.RunJar.main(RunJar.java:156)
>
>
>
> any suggestions how to approach this?
>
> is it my Hadoop version too out of date?
>
> thanks!
>
> Best ransom

Mime
View raw message