hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amit Sharma <amitsharma1...@gmail.com>
Subject Re: Hive Custom UDF - "hive.aux.jars.path" not working
Date Fri, 26 Aug 2011 19:13:40 GMT
Do you know anyway in which this can be done in  "Hive Server" ?

Amit

On Tue, Aug 23, 2011 at 11:21 AM, Chinna Rao Lalam 72745 <
chinnarao@huawei.com> wrote:

>
> Hi Amit,
>
>  Pls check this issue HIVE-1405 it will help u .This issue targeting same
> scenario.
>
> Thanks
> Chinna Rao Lalam
>
> > Hi Chinna,
> >   That worked, Thanks a lot. So once the jar is picked up, is
> > there a way
> > to create a temporary function, that is retained even if i quit the
> > interactive shell and start it again?  Or do i have to use the create
> > command to register the function everytime?
> >
> > Thanks.
> > Amit
> >
> > On Mon, Aug 22, 2011 at 10:00 PM, Chinna <chinnarao@huawei.com> wrote:
> >
> > >  Hi,****
> > >
> > >   ****
> > >
> > >   U need to mention the jar like this,****
> > >
> > > ** **
> > >
> > > ~/Documents/workspace/Hive_0_7_1/build/dist/conf$grep aux hive-
> > site.xml>
> > >
> >
> <property><name>hive.aux.jars.path</name><value>/Users/amsharma/dev/Perforce/development/depot/dataeng/hive/dist>
> */{URJARNAME}.jar*</value></property>
> > >
> > > ****
> > >
> > > ** **
> > >
> > >  U r using CLI mode  so after changing the value if u start
> > shell that is
> > > ok...and in another mode also we can start hive that is
> > hiveserver this case
> > > after changing the value u need to restart the hive server****
> > >
> > > ** **
> > >
> > > Thanks,****
> > >
> > > Chinna Rao Lalam****
> > >  ------------------------------
> > >
> > > *From:* Amit Sharma [mailto:amitsharma1708@gmail.com]
> > > *Sent:* Tuesday, August 23, 2011 3:35 AM
> > >
> > > *To:* user@hive.apache.org
> > > *Subject:* Re: Hive Custom UDF - "hive.aux.jars.path" not
> > working****>
> > > ** **
> > >
> > > Hi Vaibhav,
> > >   Excuse my ignorance as im a little new to Hive. What do you
> > mean by
> > > restart the Hive Server? I am using the Hive Interactive shell
> > for my work.
> > > So i start the shell after modifying the config variable. Which
> > server do i
> > > need to restart?
> > >
> > > Amit****
> > >
> > > On Mon, Aug 22, 2011 at 2:49 PM, Aggarwal, Vaibhav
> > <vaggarw@amazon.com>> wrote:****
> > >
> > > Did you restart the hive server after modifying the hive-
> > site.xml settings?
> > > ****
> > >
> > > I think you need to restart the server to pick up the latest
> > settings in
> > > the config file.****
> > >
> > >  ****
> > >
> > > Thanks****
> > >
> > > Vaibhav****
> > >
> > >  ****
> > >
> > > *From:* Amit Sharma [mailto:amitsharma1708@gmail.com]
> > > *Sent:* Monday, August 22, 2011 2:42 PM
> > > *To:* user@hive.apache.org
> > > *Subject:* Hive Custom UDF - "hive.aux.jars.path" not working****
> > >
> > >  ****
> > >
> > > Hi,
> > >   I build custom UDFS for hive and they seem to work fine when i
> > explicitly> register the jars using the "add jar <jarname>"
> > command or put in in the
> > > environment variable "HIVE_AUX_JARS_PATH". But if i add it as a
> > > configuration variable in the hive-site.xml file and try to
> > register the
> > > function using "create temporary function <functionname> as
> > 'funciton' ", it
> > > cannot find the jar. Any idea whats going on here?
> > >
> > > Here is the snippet from hive-site.xml:
> > >
> > > ~/Documents/workspace/Hive_0_7_1/build/dist/conf$grep aux hive-
> > site.xml>
> > >
> >
> <property><name>hive.aux.jars.path</name><value>/Users/amsharma/dev/Perforce/development/depot/dataeng/hive/dist</value></property>>
> > > Amit****
> > >
> > > ** **
> > >
> >
>

Mime
View raw message