hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mayuresh <mayuresh.kshirsa...@gmail.com>
Subject Re: Hive+Hbase+Hadoop version compatibility
Date Thu, 28 Jul 2011 03:11:45 GMT
I finally gave up on setting this up, and installed cloudera cdh3 stack. The
versions are:
hadoop-0.20.2+923.97
hive-0.7.1+42.4
hbase-0.90.3+15.3
zookeeper-3.3.3+12.12

On Tue, Jul 26, 2011 at 11:16 PM, Viral Bajaria <viral.bajaria@gmail.com>wrote:

> My current setup uses
> hadoop: 0.20.2 (with some patches... don't remember which one's)
> hbase : 0.89
> hive : 0.5
>
> I don't need derby db since I use mysql as my metastore. hbase 0.89 should
> work with 0.20
>
> -Viral
>
> On Mon, Jul 25, 2011 at 7:59 PM, Mayuresh <mayuresh.kshirsagar@gmail.com>wrote:
>
>> Any guidance folks?
>> On Jul 25, 2011 7:45 PM, "Mayuresh" <mayuresh.kshirsagar@gmail.com>
>> wrote:
>> > Hi,
>> >
>> > Overcame this problem. Had to copy some derby jars into hive libs.
>> >
>> > however after this too, it fails with class not found exception for the
>> > class zookeeperexception.
>> >
>> > Then checked that the hive version comes with hbase 0.89.0 hbase jars.
>> >
>> > So it all boils down again on the versions of the stack.
>> >
>> > Can you please guide me around what might be the best alternative? Now I
>> am
>> > going to try hbase 0.89.0. However I don't know whether I can make it
>> work
>> > as it requires hadoop 0.20-append.
>> >
>> > Please guide me around the best possible combination.
>> >
>> > Thanks,
>> > Mayuresh
>> > On Jul 25, 2011 4:26 PM, "Mayuresh" <mayuresh.kshirsagar@gmail.com>
>> wrote:
>>
>
>


-- 
-Mayuresh

Mime
View raw message