hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Travis Powell" <tpow...@tealeaf.com>
Subject RE: Hive Parse Error
Date Tue, 28 Jun 2011 23:44:37 GMT
Don't bother trying to do Hive on Cygwin w/ Windows.

I tried a million different configurations and could never get it to
work.

I'd recommend downloading the Cloudera VM and the free VMWare player
instead for development work, since those are tried-and-true work
environments.

Travis Powell / tpowell@tealeaf.com 
-----Original Message-----
From: Sal Scalisi [mailto:sals99@hotmail.com] 
Sent: Tuesday, June 28, 2011 4:31 PM
To: user@hive.apache.org
Subject: Hive Parse Error

Hi,

I'm new to Hive and hoping someone can help me resolve an issue.  I've 
Googled it, but have not been able to find a solution.
Below is my configuration info:

Windows XP SP3
Cygwin 1.7.9
Hadoop 0.20.2 (running on a single-node in a pseudo-distributed mode)
Hive 0.7.1
Java 1.6.0_26

I've been able to get Hadoop up and running, and have run several of the

sample hadoop jobs (ie wordcount).  I've installed hive and configured 
it as described on the Apache Hive Getting Started page:

https://cwiki.apache.org/confluence/display/Hive/GettingStarted#GettingS
tarted-Hive%2CMapReduceandLocalMode

I've configure the hadoop file system as follows:

$HADOOP_HOME/bin/hadoop fs -mkdir       /tmp
$HADOOP_HOME/bin/hadoop fs -mkdir       /user/hive/warehouse
$HADOOP_HOME/bin/hadoop fs -chmod g+w   /tmp
$HADOOP_HOME/bin/hadoop fs -chmod g+w   /user/hive/warehouse

I've set $HIVE_HOME to the hive install directory.

I kept the default configuration for the metadata store.

When I run hive, I get the 'hive>' prompt as expected.

When I try to execute SHOW TABLES;, I get the following error:

hive> SHOW TABLES;
FAILED: Parse Error: line 1:0 cannot recognize input near 'SWTABLES' 
'<EOF>' '<EOF>'

The log shows the following error:
2011-06-28 16:11:59,234 ERROR ql.Driver 
(SessionState.java:printError(343)) - FAILED: Parse Error: line 1:0 
cannot recognize input near 'SWTABLES' '<EOF>' '<EOF>'

org.apache.hadoop.hive.ql.parse.ParseException: line 1:0 cannot 
recognize input near 'SWTABLES' '<EOF>' '<EOF>'

     at 
org.apache.hadoop.hive.ql.parse.ParseDriver.parse(ParseDriver.java:438)
     at org.apache.hadoop.hive.ql.Driver.compile(Driver.java:327)
     at org.apache.hadoop.hive.ql.Driver.run(Driver.java:736)
     at
org.apache.hadoop.hive.cli.CliDriver.processCmd(CliDriver.java:164)
     at
org.apache.hadoop.hive.cli.CliDriver.processLine(CliDriver.java:241)
     at org.apache.hadoop.hive.cli.CliDriver.main(CliDriver.java:456)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at 
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.jav
a:39)
     at 
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessor
Impl.java:25)
     at java.lang.reflect.Method.invoke(Method.java:597)
     at org.apache.hadoop.util.RunJar.main(RunJar.java:156)

I've tried to reinstall hive, but that has not helped.  Any suggestions 
anyone might have is greatly appreciated.

-Sal

Mime
View raw message