hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From abhishek pathak <forever_yours_a...@yahoo.co.in>
Subject Wrong file format error
Date Mon, 21 Mar 2011 10:02:57 GMT
Hi all,

I have created an external hive table with the STORED AS SEQUENCEFILE 
option.However,when I try to load a blank file into that table it gives me the 
following error:

Failed with exception Wrong file format. Please check the file's format.
FAILED: Execution Error, return code 1 from 
org.apache.hadoop.hive.ql.exec.MoveTask

I also tried by loading a small .seq file (generated by flume) instead of the 
blank file,however i got the same error.
I already have many .seq files stored in the hdfs with partitons already made as 

folders.I was earlier using hive with that hdfs but the table created was of 
TEXTFILE type,and I dropped it and created the exact same table with 
SEQUENCEFILE type,so as to boost performance.However,i am not able to load data 
in hive due to this error.
I would appreciate it if someone could guide me through this.

Regards,
Abhishek



Mime
View raw message