hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Sichi <jsi...@fb.com>
Subject Re: Hbase Hive Intergration (for the latest versions)
Date Mon, 28 Feb 2011 19:01:31 GMT
You should try the latest Hive (either trunk or the 0.7 release branch) instead.

JVS

On Feb 28, 2011, at 5:41 AM, Vivek Krishna wrote:

> In short, I am trying to make hbase_handler to work with hive-0.6 and hbase-0.90.1.
> 
> I am trying to integrate Hbase and Hive.  There is a pretty good documentation at http://wiki.apache.org/hadoop/Hive/HBaseIntegration
.
> 
> But looks like they have become old.  The hbase_handler was written for hbase-0.20* ,
with the latest version of hbase-0.9* the integration does not work.
> 
> I tried the handler to work with hbase_0.20, but this version of hbase does not work.
 It gives 
> "java.lang.UnsupportedClassVersionError: Bad version number in .class file" error.
> 
> I tried following the procedure of copying the newer hbase jar to the hive and recompiling
it.  There were couple of errors with the deprecated classes.
> org.apache.hadoop.hbase.io.RowResult and org.apache.hadoop.hbase.io.BatchUpdate.
> 
> The description at these deprecated classes were "* @deprecated As of hbase 0.20.0, replaced
by new Get/Put/Delete/Result-based API."
> 
> If any one could let me know how to use these methods, it would be really helpful! 
> 
> Viv
> 
> 


Mime
View raw message