hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ning Zhang <nzh...@fb.com>
Subject Re: Dynamic partition set to null
Date Sun, 13 Feb 2011 16:16:09 GMT
Khaled, which version of Hive are you running? I tried a similar query in trunk (0.7.0-SNAPSHOT)
and it worked. 

The error does't mean the data is wrong (ds=null), it means the compiled query plan doesn't
indicate it is a dynamic partition (which is very unlikely for this simple query) or the MoveTask
didn't found the location of the intermediate results so that it cannot come up with the list
of dynamic partitions generated. I think it is very like to be the latter case in that the
external table is stored in s3, and we never tried that in our development. All we assume
is that data are in HDFS directories. So you might want to first do a 'explain extended <your_insert_query>'
and if the insert are inserted into an s3 location first. If so, it's might be where the bug
is. You might want to contact Amazon EMR developers to see if there are any issues in dynamic
partitions for data loaded in s3. 

Ning

On Feb 12, 2011, at 11:38 PM, <khassounah@mediumware.net>
 <khassounah@mediumware.net> wrote:

> Hi Pat.. I have hive.exec.dynamic.partition.mode=nonstrict and
> hive.exec.dynamic.partition=true. That let hive accept the dynamic
> partitions, but it still fails.
> 
> Khaled
> 
>> Check that you have hive.exec.dynamic.partition.mode set to false.  That
>> or have a static partition column first in your partitioning clause.
>> 
>> Pat
>> 
>> 
>> 
>> -- Sent from my Palm Pre
> 
> 


Mime
View raw message