hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Daniel Cryans <jdcry...@apache.org>
Subject Re: Hive/Hbase Integration Error
Date Fri, 07 Jan 2011 17:57:26 GMT
While testing other things yesterday on my local machine, I
encountered the same stack traces. Like I said the other day, which
you seem to have discarded while debugging your issue, is that it's
not able to connect to Zookeeper.

Following the cue, I added these lines in HBaseStorageHandler.setConf():

System.out.println(hbaseConf.get("hbase.zookeeper.quorum"));
System.out.println(hbaseConf.get("hbase.zookeeper.property.clientPort"));

It showed me this when trying to create a table (after recompiling):

localhost
21810

I was testing with 0.89 and the test jar includes a hbase-site.xml
which has the port 21810 instead of the default 2181. I remembered
that it's a known issue that has since been fixed for 0.90.0, so
removing that jar fixed it for me.

I'm not saying that in your case it's the same fix, but at least by
debugging those configurations you'll know where it's trying to
connect and then you'll be able to get to the bottom of your issue.

J-D

On Fri, Jan 7, 2011 at 4:54 AM, Adarsh Sharma <adarsh.sharma@orkash.com> wrote:
> John Sichi wrote:
>
> On Jan 6, 2011, at 9:53 PM, Adarsh Sharma wrote:
>
>
> I want to know why it occurs in hive.log
>
> 2011-01-05 15:19:36,783 ERROR DataNucleus.Plugin
> (Log4JLogger.java:error(115)) - Bundle "org.eclipse.jdt.core" requires
> "org.eclipse.core.resources" but it cannot be resolved.
>
>
>
> That is a bogus error; it always shows up, so you can ignore it.
>
>
>
> And use this new Hive build but I am sorry but the error remains the same.
>
>
> Then I don't know...probably still some remaining configuration error.  This
> guy seems to have gotten it working:
>
> http://mevivs.wordpress.com/2010/11/24/hivehbase-integration/
>
>
> Thanks a lot John , I know this link as i have start working by following
> this link in the past.
>
> But I think I have to research on below exception or warning to solve this
> issue.
>
>  2011-01-05 15:20:12,185 WARN  zookeeper.ClientCnxn
> (ClientCnxn.java:run(967)) - Exception closing session 0x0 to
> sun.nio.ch.SelectionKeyImpl@561279c8
>  java.net.ConnectException: Connection refused
>        at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
>        at
> sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:574)
>        at
> org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:933)
>  2011-01-05 15:20:12,188 WARN  zookeeper.ClientCnxn
> (ClientCnxn.java:cleanup(1001)) - Ignoring exception during shutdown input
>  java.nio.channels.ClosedChannelException
>        at
> sun.nio.ch.SocketChannelImpl.shutdownInput(SocketChannelImpl.java:638)
>        at sun.nio.ch.SocketAdaptor.shutdownInput(SocketAdaptor.java:360)
>        at
> org.apache.zookeeper.ClientCnxn$SendThread.cleanup(ClientCnxn.java:999)
>        at
> org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:970)
>  2011-01-05 15:20:12,188 WARN  zookeeper.ClientCnxn
> (ClientCnxn.java:cleanup(1006)) - Ignoring exception during shutdown output
>  java.nio.channels.ClosedChannelException
>        at
> sun.nio.ch.SocketChannelImpl.shutdownOutput(SocketChannelImpl.java:649)
>        at sun.nio.ch.SocketAdaptor.shutdownOutput(SocketAdaptor.java:368)
>        at
> org.apache.zookeeper.ClientCnxn$SendThread.cleanup(ClientCnxn.java:1004)
>        at
> org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:970)
>  2011-01-05 15:20:12,621 WARN  zookeeper.ClientCnxn
> (ClientCnxn.java:run(967)) - Exception closing session 0x0 to
> sun.nio.ch.SelectionKeyImpl@799dbc3b
>
>   Please help me, as i am not able to solve this problem.
>
>  Also I want to add one more thing that my hadoop Cluster is of 9 nodes and
> 8 nodes act as Datanodes,Tasktrackers and Regionservers.
>
>
>
>
>  Best Regards
>
>  Adarsh Sharma
>
> JVS
>
>
>

Mime
View raw message