hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adarsh Sharma <>
Subject Zookeeper Package Needed or Not
Date Mon, 10 Jan 2011 12:16:29 GMT
Dear all,

I want to know that whether it is necessary to download Zookeeper 
package for Hive/Hbase Integration or it is handled by hbase by in Hbase-site.xml.

I am stucked to run Hive/Hbase Integration.

I am facing th issue mentioned in Hive/Hbase Integration wiki page.


The handler requires Hadoop 0.20 or higher, and has only been tested 
with dependency versions hadoop-0.20.0, hbase-0.20.3 and 
zookeeper-3.2.2. If you are not using hbase-0.20.3, you will need to 
rebuild the handler with the HBase jar matching your version, and change 
the --auxpath above accordingly. Failure to use matching versions will 
lead to misleading connection failures such as MasterNotRunningException 
<> since the 
HBase RPC protocol changes often.


Can Someone Please which Hive and Hbase version is needed to escape from 
this error.
I am constantly facing this issue.

And Please guide me that which servers are needed in 
I configured hadoop-0.20.2 on 9 servers. ( Namenode, Jobtracker , HMaster, Hive Package holder )  ( datanodes , tasktracker , HRegionservers )

I set to * . *I think 
this causes error on Zookeeper logs. Please help i am not able to 
overcomed it.
2011-01-10 11:49:58,419 WARN 
org.apache.zookeeper.server.quorum.QuorumCnxManager: Interrupted while 
waiting for message on queue

If needed I will send my error logs. Please let me know.
Thanks & Best regards

Adarsh Sharma

View raw message