hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vivek Mishra <vivek.mis...@impetus.co.in>
Subject Running a HiveClient with create external table HBase
Date Fri, 03 Dec 2010 08:18:26 GMT
Hi,
Currently I am facing random behavior while trying to create a java client for Hive hbase
integration.
Case: I am trying to create a hive table for existing HBase table. So i have started hiveserver
via  /hive -service hiveserver.     In logs I can see it is printing by my sql with "CREATE
EXTERNAL TABLE". But somehow that table is not getting created in Hive. Interesting point
is running the sql command from command line with Hive is running fine.

This behavior is random. Sometimes it shows me all created tables in Hive(when I use "SHOW
TABLES").

Does it have  something to do with 'metastore_db'?


Any idea?

________________________________
Register for Impetus Webinar on 'Building Highly Scalable and Flexible SaaS Solutions' on
Dec 10 (10:00 a.m. PT).

Click http://www.impetus.com to know more. Follow us on www.twitter.com/impetuscalling.

NOTE: This message may contain information that is confidential, proprietary, privileged or
otherwise protected by law. The message is intended solely for the named addressee. If received
in error, please destroy and notify the sender. Any use of this email is prohibited when received
in error. Impetus does not represent, warrant and/or guarantee, that the integrity of this
communication has been maintained nor that the communication is free of errors, virus, interception
or interference.

Mime
View raw message