hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gokul Pillai <gokoolt...@gmail.com>
Subject Re: ngrams() and context_ngrams() available in Hive 0.6 or 0.7 ?
Date Mon, 08 Nov 2010 23:11:15 GMT
Thanks John, that worked.

On Fri, Nov 5, 2010 at 8:55 PM, John Sichi <jsichi@facebook.com> wrote:

> They are only present in trunk, so they won't be in a release until 0.7.
>
> Since they are UDAF's, you might be able to compile them by building trunk
> and then plug them into 0.6 via CREATE TEMPORARY FUNCTION.
>
> JVS
>
> On Nov 5, 2010, at 5:20 PM, Gokul Pillai wrote:
>
> > According to the Hive wiki, ngrams() and context_ngrams() are available
> in Hive. This is awesome.
> > However, when I quickly logged into my Hive 0.5 instance to check it out,
> it dissapointed me with this error:
> >
> > FAILED: Error in semantic analysis: line 1:14 Invalid Function sentences
> >
> > I believe this is because this implementation happened after hive 0.5.
> Now I would like to get the version that has this and the hive Jira seems to
> say it is only part of 0.7 (
> http://mail-archives.apache.org/mod_mbox/hadoop-hive-dev/201007.mbox/%3c33229528.35721280274438668.JavaMail.jira@thor%3e)
>  but maybe I am wrong here.
> >
> > Is there a stable version of Hive that includes this implementation. This
> link (http://svn.apache.org/repos/asf/hive/trunk/) points to Hive 0.6 and
> not 0.7
> >
> > Thanks in advance
> >
> > Gokul
>
>

Mime
View raw message