hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hdev ml <hde...@gmail.com>
Subject Runtime exception while running Hive
Date Tue, 05 Oct 2010 19:01:11 GMT
Hi all,

I installed hadoop-0.21.0 and hive-0.5.0-bin and it is giving me following
error when trying to run hive CLI

Is there anything wrong that I am doing?

[user@machine bin]$ ./hive
Exception in thread "main" java.lang.RuntimeException: Could not load shims
in class null
        at
org.apache.hadoop.hive.shims.ShimLoader.loadShims(ShimLoader.java:86)
        at
org.apache.hadoop.hive.shims.ShimLoader.getHadoopShims(ShimLoader.java:62)
        at org.apache.hadoop.hive.cli.CliDriver.main(CliDriver.java:234)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.hadoop.util.RunJar.main(RunJar.java:192)
Caused by: java.lang.NullPointerException
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:169)
        at
org.apache.hadoop.hive.shims.ShimLoader.loadShims(ShimLoader.java:83)
        ... 7 more


Is this compatibility issue? I followed all the directions of installing
HIVE.

Any help is really appreciated, as I am unable to proceed further.

Thanks,
Harshad

Mime
View raw message