hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steven Wong <sw...@netflix.com>
Subject RE: Exception in hive startup
Date Thu, 14 Oct 2010 01:14:47 GMT
You need to run hive_root/build/dist/bin/hive, not hive_root/bin/hive.


From: hdev ml [mailto:hdevml@gmail.com]
Sent: Wednesday, October 13, 2010 2:18 PM
To: hive-user@hadoop.apache.org
Subject: Exception in hive startup

Hi all,

I installed Hadoop 0.20.2 and installed hive 0.5.0.

I followed all the instructions on Hive's getting started page for setting up environment
variables like HADOOP_HOME

When I run from command prompt in the hive installation folder as "bin/hive" it gives me following
exception

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/hadoop/hive/conf/HiveConf
        at java.lang.Class.forName0(Native Method)
        at java.lang.Class.forName(Class.java:247)
        at org.apache.hadoop.util.RunJar.main(RunJar.java:149)
Caused by: java.lang.ClassNotFoundException: org.apache.hadoop.hive.conf.HiveConf
        at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
        ... 3 more

Please note that my Hadoop installation is working fine.

What could be the cause of this? Anybody has any idea?

Thanks
Harshad

Mime
View raw message