hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chaitanya Krishna <chaitanyavv.ii...@gmail.com>
Subject Re: Why are so many versions of hadoop tarballs being deployed in build?
Date Mon, 20 Sep 2010 17:46:54 GMT
Thanks John for the reply. I'm sure removing support for pre-0.20 hadoop
versions will considerably reduce the time taken to build and the size of
build folder as well (currently, build/hadoopcore appears to 522MB!).

-Chaitanya

On Mon, Sep 20, 2010 at 10:58 PM, John Sichi <jsichi@facebook.com> wrote:

> We build shims against a number of different versions of Hadoop to verify
> API compatibility.  We're dropping support for pre-0.20 Hadoop versions
> soon, so that should reduce the overhead here considerably.
>
> JVS
>
> On Sep 19, 2010, at 11:24 PM, Chaitanya Krishna wrote:
>
> > Hi,
> >
> >  I've just started on Hive by following the wiki and trying to set it up.
> As mentioned in the wiki, I run "ant package". But when its run, I find that
> there are several versions of hadoop tarballs that are being deployed in
> build/hadoopcore. When I did a bit of search for the cause of it, I find
> that this comes because of the ant-target "compile" in shims/build.xml, that
> is called as an iteration of target "compile" in parent build.xml.  I wonder
> if this behaviour is to be expected or is it a bug?
> >
> > Please reply
> >
> > Thanks,
> > Chaitanya.
>
>

Mime
View raw message