hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Katukuri, Jay" <>
Subject RE: Hive Instllation Problem - Pls help
Date Wed, 24 Mar 2010 02:11:17 GMT
Hello all,

On our cluster (using redhat enterprise 5), we have hadoop 0.18.3 installed.

When I do "show tables" on hive prompt, I get the following error

java.lang.NoSuchFieldError: type
        at org.apache.hadoop.hive.ql.parse.HiveLexer.mKW_SHOW(
        at org.apache.hadoop.hive.ql.parse.HiveLexer.mTokens(
        at org.antlr.runtime.Lexer.nextToken(
        at org.antlr.runtime.CommonTokenStream.fillBuffer(
        at org.antlr.runtime.CommonTokenStream.LT(
        at org.apache.hadoop.hive.ql.parse.HiveParser.statement(
        at org.apache.hadoop.hive.ql.parse.ParseDriver.parse(
        at org.apache.hadoop.hive.ql.Driver.compile(
        at org.apache.hadoop.hive.cli.CliDriver.processCmd(
        at org.apache.hadoop.hive.cli.CliDriver.processLine(
        at org.apache.hadoop.hive.cli.CliDriver.main(
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.apache.hadoop.util.RunJar.main(
        at org.apache.hadoop.mapred.JobShell.main(

I am getting this error for both binaries "hive_0.5.0" and "hive _0.4.1"

I have also built hive from source . I got the source code from

I get the same error while using hive script from hive built from source.

I have tried different versions of "antlr_runtime jars" by placing them into the lib folder
for both binaries and hive built from source. 

Any help is appreciated.


View raw message