hive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joydeep Sen Sarma <>
Subject RE: Error loading data from HDFS into Hive
Date Wed, 21 Jan 2009 04:23:55 GMT
Can u do a describe extended on the ip_locations table?

it will have a location string. It's possible that the location spec in it does not have full
uri (perhaps the table was created before the warehouse.dir was filled in?)

some of these issues were fixed in a jira fixed by Prasad a couple of days back (where the
metastore uses the namenode schema/authority by default if warehouse.dir is not filled in
I think)

From: Aaron Kimball []
Sent: Tuesday, January 20, 2009 8:02 PM
Subject: Re: Error loading data from HDFS into Hive

I should also add that I have set the hive.metastore.warehouse.dir in conf/hive-default.xml
to include the full URI to /user/hive/warehouse (Same HDFS host)

- Aaron
On Tue, Jan 20, 2009 at 7:56 PM, Aaron Kimball <<>>
Hi all,

I generated some data using a MapReduce process (output in HDFS) and want to play with it
in Hive.

The output is a set of part-nnnn files in a directory.

I created the table and tried to run the statement:
LOAD DATA INPATH 'hdfs://<>'
INTO TABLE ip_locations;

It failed with:

FAILED: Error in semantic analysis: Path is not legal 'hdfs://<>':
Cannot load data across filesystems, use load data local
Time taken: 1.51 seconds

The fully-qualified hdfs URI I am using matches exactly against the<>
in $HADOOP_HOME/conf/hadoop-site.xml. Can anyone suggest what I might be doing wrong, or where
I should look for more information?

I also tried just using "/user/aaron/ip_addr_tables/0/part-00000" and "ip_addr_tables/0/part-00000"

- Aaron

View raw message