hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zoltan Haindrich (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-20071) Migrate to jackson 2.x and prevent usage
Date Mon, 29 Jul 2019 15:47:00 GMT

    [ https://issues.apache.org/jira/browse/HIVE-20071?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16895384#comment-16895384
] 

Zoltan Haindrich commented on HIVE-20071:
-----------------------------------------

getting back to this conversation: I still see that preventing imports is probably better;
we don't really have direct control on what the projects we are importing doing - for example
we can migrate to the newer jackson librabry without having to update all our dependencies
to use the newer one...

I've seen some issues arise from the fact that sometimes the IDE imports some guava library
from a shaded one....the usage of those libraries should be prevented.

> Migrate to jackson 2.x and prevent usage
> ----------------------------------------
>
>                 Key: HIVE-20071
>                 URL: https://issues.apache.org/jira/browse/HIVE-20071
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Zoltan Haindrich
>            Priority: Major
>         Attachments: restrict_usage.patch
>
>
> there are still some places where jackson 1.x is being used; even thru it's not even
referenced from hive's pom.xml-s
> {code}
> git grep -E 'import org.codehaus.jackson'|wc -l
> 106
> {code}



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message