hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manoj Narayanan (JIRA)" <>
Subject [jira] [Commented] (HIVE-21713) Explain consistency Task/Operator
Date Mon, 27 May 2019 07:52:00 GMT


Manoj Narayanan commented on HIVE-21713:

[~kgyrtkirk] I assume you are referring to changing the name given here, 



I assume it must be a straight forward change. But I had a few questions,

it seems at least some of  Explain classes are named as Operator. I did a code search and
66 classes had named as Operator out of total 600 odd ones.  Only 1 of them had Task in the
name. If that is the case, is it a convention to have Operator in the name ? So is it OK
to continue to name it as 'Move Operator' ? Just wanted to confirm before proceeding with
a  patch. 

find . -name \*.java | grep -v Test | xargs grep  @Explain | grep display | grep -i operator
| wc -l


find . -name \*.java | grep -v Test | xargs grep  @Explain | grep display | wc -l


find . -name \*.java | grep -v Test | xargs grep  @Explain | grep display | grep -i task
|wc -l



> Explain consistency Task/Operator
> ---------------------------------
>                 Key: HIVE-21713
>                 URL:
>             Project: Hive
>          Issue Type: Improvement
>            Reporter: Zoltan Haindrich
>            Priority: Major
> there seems to be some inconsistency what gets printed in the explain;
> for example "MoveTask" is shown as "Move Operator" in the explain
> Becase Tasks and Operators are basically different things - this should be corrected
as it may cause confusion

This message was sent by Atlassian JIRA

View raw message