hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antal Sinkovits (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HIVE-20904) Yetus fails to resolve module dependencies due to usage of exec plugin in metastore-server
Date Mon, 12 Nov 2018 11:03:01 GMT

     [ https://issues.apache.org/jira/browse/HIVE-20904?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Antal Sinkovits updated HIVE-20904:
-----------------------------------
    Attachment: HIVE-20904.01.patch

> Yetus fails to resolve module dependencies due to usage of exec plugin in metastore-server
> ------------------------------------------------------------------------------------------
>
>                 Key: HIVE-20904
>                 URL: https://issues.apache.org/jira/browse/HIVE-20904
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Antal Sinkovits
>            Assignee: Antal Sinkovits
>            Priority: Major
>         Attachments: HIVE-20904.01.patch
>
>
> metastore-server uses exec-maven-plugin to generate metastore-site.xml.template with
ConfTemplatePrinter.
> It expects some arguments. 
> Because yetus also uses the exec-maven-plugin to determine the order of the modules to
be built, but with zero params, the execution fails.
> https://github.com/apache/yetus/blob/6ebaa1119e611db14f219e289e33ab8ac5c254a7/precommit/src/main/shell/test-patch.d/maven.sh#L658
> Steps to reproduce the issue:
> mvn -q exec:exec -Dexec.executable=pwd -Dexec.args=''



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message