hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lefty Leverenz (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HIVE-16336) Rename hive.spark.use.file.size.for.mapjoin to hive.spark.use.ts.stats.for.mapjoin
Date Mon, 24 Jul 2017 06:50:00 GMT

    [ https://issues.apache.org/jira/browse/HIVE-16336?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16097990#comment-16097990
] 

Lefty Leverenz edited comment on HIVE-16336 at 7/24/17 6:49 AM:
----------------------------------------------------------------

Doc note:  This adds *hive.spark.use.ts.stats.for.mapjoin* to HiveConf.java, replacing and
removing *hive.spark.use.file.size.for.mapjoin* which was added in release 2.3.0 by HIVE-15489.

* [Configuration Properties -- Spark | https://cwiki.apache.org/confluence/display/Hive/Configuration+Properties#ConfigurationProperties-Spark]
** [hive.spark.use.ts.stats.for.mapjoin | https://cwiki.apache.org/confluence/display/Hive/Configuration+Properties#ConfigurationProperties-hive.spark.use.ts.stats.for.mapjoin]
** [hive.spark.use.file.size.for.mapjoin | https://cwiki.apache.org/confluence/display/Hive/Configuration+Properties#ConfigurationProperties-hive.spark.use.file.size.for.mapjoin]

I won't add a TODOC label because I just took care of the documentation.


was (Author: lefty@hortonworks.com):
Doc note:  This adds *hive.spark.use.ts.stats.for.mapjoin* to HiveConf.java, replacing and
removing *hive.spark.use.file.size.for.mapjoin* which was added in release 2.3.0 by HIVE-15489.

* [Configuration Properties -- Spark | https://cwiki.apache.org/confluence/display/Hive/Configuration+Properties#ConfigurationProperties-Spark]
** [hive.spark.use.ts.stats.for.mapjoin | https://cwiki.apache.org/#ConfigurationProperties-hive.spark.use.ts.stats.for.mapjoin]
** [hive.spark.use.file.size.for.mapjoin | https://cwiki.apache.org/#ConfigurationProperties-hive.spark.use.file.size.for.mapjoin]

I won't add a TODOC label because I just took care of the documentation.

> Rename hive.spark.use.file.size.for.mapjoin to hive.spark.use.ts.stats.for.mapjoin
> ----------------------------------------------------------------------------------
>
>                 Key: HIVE-16336
>                 URL: https://issues.apache.org/jira/browse/HIVE-16336
>             Project: Hive
>          Issue Type: Bug
>          Components: Configuration
>            Reporter: Chao Sun
>            Assignee: Chao Sun
>             Fix For: 3.0.0
>
>         Attachments: HIVE-16336.0.patch, HIVE-16336.1.patch
>
>
> The name {{hive.spark.use.file.size.for.mapjoin}} is confusing. It indicates that HoS
uses file size for mapjoin but in fact it still uses (in-memory) data size. We should change
it.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message