hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aihua Xu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-16911) Upgrade groovy version to 2.4.11
Date Mon, 19 Jun 2017 16:34:00 GMT

    [ https://issues.apache.org/jira/browse/HIVE-16911?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16054291#comment-16054291
] 

Aihua Xu commented on HIVE-16911:
---------------------------------

[~ychena] I can't find the doc for groovy incompatibility issues, but since it's minor version
upgrade 2.4.4=>2.4.11, I assume it should be. The test failures shouldn't be related, but
I will rerun to make sure.

> Upgrade groovy version to 2.4.11
> --------------------------------
>
>                 Key: HIVE-16911
>                 URL: https://issues.apache.org/jira/browse/HIVE-16911
>             Project: Hive
>          Issue Type: Improvement
>          Components: Hive
>    Affects Versions: 3.0.0
>            Reporter: Aihua Xu
>            Assignee: Aihua Xu
>         Attachments: HIVE-16911.1.patch
>
>
> Hive currently uses groovy 2.4.4 which has security issue (https://access.redhat.com/security/cve/cve-2016-6814).
Need to upgrade to 2.4.8 or later. 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message