hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gunther Hagleitner (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-16477) Rename tez edges to something more appropriate
Date Wed, 19 Apr 2017 03:56:41 GMT

    [ https://issues.apache.org/jira/browse/HIVE-16477?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15974023#comment-15974023
] 

Gunther Hagleitner commented on HIVE-16477:
-------------------------------------------

HIVE-15549 I liked those names because they describe what's happening (i.e.: ordered_exchange
isn't as clear to me as sort_partition)

> Rename tez edges to something more appropriate
> ----------------------------------------------
>
>                 Key: HIVE-16477
>                 URL: https://issues.apache.org/jira/browse/HIVE-16477
>             Project: Hive
>          Issue Type: Improvement
>          Components: llap, Tez
>    Affects Versions: 3.0.0
>            Reporter: Prasanth Jayachandran
>            Assignee: Prasanth Jayachandran
>
> Edge names in tez/llap can be renamed to better reflect the actual operation
> Proposing the following
> SIMPLE_EDGE -> SORTED_SHUFFLE (or ORDERED_EXCHANGE)
> BROADCAST_EDGE -> BROADCAST
> CONTAINS -> UNION (or leave it CONTAINS)
> CUSTOM_EDGE -> BUCKET_JOIN
> CUSTOM_SIMPLE_EDGE -> UNSORTED_SHUFFLE (or UNORDERED_EXCHANGE)
> [~hagleitn] [~gopalv] [~sseth] any thoughts on the renames?



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message