hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sahil Takiar (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (HIVE-16192) QTestUtil doesn't correctly set the last command when running "test" commands
Date Mon, 13 Mar 2017 22:27:41 GMT

     [ https://issues.apache.org/jira/browse/HIVE-16192?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sahil Takiar reassigned HIVE-16192:
-----------------------------------


> QTestUtil doesn't correctly set the last command when running "test" commands 
> ------------------------------------------------------------------------------
>
>                 Key: HIVE-16192
>                 URL: https://issues.apache.org/jira/browse/HIVE-16192
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Sahil Takiar
>            Assignee: Sahil Takiar
>
> {{QTestUtil}} has some logic to execute "test" commands, these are typically "crypto"
commands. These "test" commands, aren't valid HiveQL, but can be run in qtests.
> The "crypto" commands are used to setup encryption keys and zones for the {{TestEncryptedHDFSCliDriver}}
> When debugging HIVE-15991 I noticed that the command printed out in {{QTestUtil.failed}}
is incorrect. It's printing out the last Hive command run, even if a more recent "test" command
has been run. This can be very misleading when debugging qtest failures.
> The attached patch updates the {{QTestUtil.executeTestCommand}} method so that is correctly
sets the last executed "test" command.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message