hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lefty Leverenz (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HIVE-15881) Use hive.exec.input.listing.max.threads variable name instead of mapred.dfsclient.parallelism.max
Date Tue, 07 Mar 2017 10:38:38 GMT

    [ https://issues.apache.org/jira/browse/HIVE-15881?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15888510#comment-15888510
] 

Lefty Leverenz edited comment on HIVE-15881 at 3/7/17 10:37 AM:
----------------------------------------------------------------

[~leftylev] I added a few configurations on the wiki used for blobstore.
[https://cwiki.apache.org/confluence/display/Hive/Configuration+Properties#ConfigurationProperties-Blobstore(i.e.AmazonS3)]


was (Author: spena):
[~leftylev] I added a few configurations on the wiki used for blobstore.
https://cwiki.apache.org/confluence/display/Hive/Configuration+Properties#ConfigurationProperties-Blobstore(i.e.AmazonS3)

> Use hive.exec.input.listing.max.threads variable name instead of mapred.dfsclient.parallelism.max
> -------------------------------------------------------------------------------------------------
>
>                 Key: HIVE-15881
>                 URL: https://issues.apache.org/jira/browse/HIVE-15881
>             Project: Hive
>          Issue Type: Task
>          Components: Query Planning
>            Reporter: Sergio Peña
>            Assignee: Sergio Peña
>            Priority: Minor
>              Labels: TODOC2.2
>             Fix For: 2.2.0
>
>         Attachments: HIVE-15881.1.patch, HIVE-15881.2.patch, HIVE-15881.3.patch, HIVE-15881.4.patch,
HIVE-15881.5.patch, HIVE-15881.6.patch
>
>
> The Utilities class has two methods, {{getInputSummary}} and {{getInputPaths}}, that
use the variable {{mapred.dfsclient.parallelism.max}} to get the summary of a list of input
locations in parallel. These methods are Hive related, but the variable name does not look
it is specific for Hive.
> Also, the above variable is not on HiveConf nor used anywhere else. I just found a reference
on the Hadoop MR1 code.
> I'd like to propose the deprecation of {{mapred.dfsclient.parallelism.max}}, and use
a different variable name, such as {{hive.get.input.listing.num.threads}}, that reflects the
intention of the variable. The removal of the old variable might happen on Hive 3.x



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message