hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Busbey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-16049) upgrade to jetty 9
Date Tue, 28 Feb 2017 00:42:45 GMT

    [ https://issues.apache.org/jira/browse/HIVE-16049?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15886935#comment-15886935
] 

Sean Busbey commented on HIVE-16049:
------------------------------------

Jetty 9.3 (the one used in this patch, also used in Hadoop and HBase) requires Java 1.8. [Looking
at the Jetty docs on version reqs|http://www.eclipse.org/jetty/documentation/current/what-jetty-version.html],
I could switch to Jetty 9.2 and it ought to work for Java 1.7, though I don't know yet how
compatible it is being colocated with 9.3.

Is there a branch I could target that is Java 1.8+ only? If not, can anyone point me to prior
dev@ discussion(s) about java version reqs so I can check background before making a case
to add a Java 1.8+ only branch?

> upgrade to jetty 9
> ------------------
>
>                 Key: HIVE-16049
>                 URL: https://issues.apache.org/jira/browse/HIVE-16049
>             Project: Hive
>          Issue Type: Improvement
>            Reporter: Sean Busbey
>            Assignee: Sean Busbey
>         Attachments: HIVE-16049.0.patch
>
>
> Jetty 7 has been deprecated for a couple of years now. Hadoop and HBase have both updated
to Jetty 9 for their next major releases, which will complicate classpath concerns.
> Proactively update to Jetty 9 in the few places we use a web server.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message