hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan Gates (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-14950) Support integer data type
Date Thu, 13 Oct 2016 21:17:20 GMT

    [ https://issues.apache.org/jira/browse/HIVE-14950?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15573209#comment-15573209
] 

Alan Gates commented on HIVE-14950:
-----------------------------------

If you're going to create KW_INTEGER as a new keyword there are several places that KW_INT
is referenced in IdentifiersParser.g that should also be updated.

I'm wondering if instead it makes more sense to change the definition of KW_INT in HiveLexer.g
to be:
{code}
KW_INT: 'INT' | 'INTEGER'
{code}
then you're guaranteed that they're interchangeable now and in the future.

> Support integer data type
> -------------------------
>
>                 Key: HIVE-14950
>                 URL: https://issues.apache.org/jira/browse/HIVE-14950
>             Project: Hive
>          Issue Type: Sub-task
>          Components: SQL
>            Reporter: Zoltan Haindrich
>            Assignee: Zoltan Haindrich
>            Priority: Minor
>         Attachments: HIVE-14950.1.patch
>
>
> maybe its just me bumping into this difference again and again...
> but it's in the sql2011 standard... 
> adding an alias for int would be easy.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message