hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gopal V (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-14933) include argparse with LLAP scripts to support antique Python versions
Date Thu, 27 Oct 2016 22:44:58 GMT

    [ https://issues.apache.org/jira/browse/HIVE-14933?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15613523#comment-15613523
] 

Gopal V commented on HIVE-14933:
--------------------------------

+1 - please add a note to the LICENSE file.

I see that Apache has approved the Python Foundation License already - https://www.apache.org/legal/resolved

> include argparse with LLAP scripts to support antique Python versions
> ---------------------------------------------------------------------
>
>                 Key: HIVE-14933
>                 URL: https://issues.apache.org/jira/browse/HIVE-14933
>             Project: Hive
>          Issue Type: Bug
>            Reporter: Sergey Shelukhin
>            Assignee: Sergey Shelukhin
>         Attachments: HIVE-14933.01.patch, HIVE-14933.patch
>
>
> The module is a standalone file, and it's under Python license that is compatible with
Apache. In the long term we should probably just move LlapServiceDriver code entirely to Java,
as right now it's a combination of part-py, part-java.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message