hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergio Peña (JIRA) <j...@apache.org>
Subject [jira] [Updated] (HIVE-13587) Set Hive pom to use Hadoop 2.6.1
Date Tue, 04 Oct 2016 14:54:20 GMT

     [ https://issues.apache.org/jira/browse/HIVE-13587?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sergio Peña updated HIVE-13587:
-------------------------------
    Fix Version/s: 2.1.1

> Set Hive pom to use Hadoop 2.6.1
> --------------------------------
>
>                 Key: HIVE-13587
>                 URL: https://issues.apache.org/jira/browse/HIVE-13587
>             Project: Hive
>          Issue Type: Sub-task
>            Reporter: Mohit Sabharwal
>            Assignee: Mohit Sabharwal
>              Labels: java8
>             Fix For: java8, 2.2.0, 2.1.1
>
>         Attachments: HIVE-13587-java8.patch
>
>
> A number of the JDK8 unit test failures are due to HADOOP-10786, fixed in Hadoop 2.6.1.

> * TestMiniHiveKdc.testLogin
> * TestHiveAuthFactory.testStartTokenManagerForDBTokenStore
> * TestHiveAuthFactory.testStartTokenManagerForMemoryTokenStore
> i.e. Hive under Kerberos is broken in Java8 unless we move dependency to hadoop 2.6.1



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message