hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zoltan Haindrich (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-12986) make sure Hive uses Antlr runtime version compatible with HPLSQL
Date Sat, 03 Sep 2016 10:27:20 GMT

    [ https://issues.apache.org/jira/browse/HIVE-12986?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15460846#comment-15460846
] 

Zoltan Haindrich commented on HIVE-12986:
-----------------------------------------

[~sershe] i was looking for tickets about upgrading antlr3 to antlr4 - I think it would make
the project more consistent...and also it will possibly make it easier to add new features
to the grammar.

Can you remember why this ticket ended up as 'wont fix'? 

> make sure Hive uses Antlr runtime version compatible with HPLSQL
> ----------------------------------------------------------------
>
>                 Key: HIVE-12986
>                 URL: https://issues.apache.org/jira/browse/HIVE-12986
>             Project: Hive
>          Issue Type: Improvement
>            Reporter: Sergey Shelukhin
>            Priority: Blocker
>
> HPLSQL requires Antlr-runtime 4.5, however Hive uses an older version. If there are no
obstacles to this, Hive should simply be upgraded to the newer version



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message