hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kashish Jain (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HIVE-12943) Use default doesnot work in Hive 1.2.1
Date Wed, 27 Jan 2016 11:49:39 GMT

     [ https://issues.apache.org/jira/browse/HIVE-12943?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kashish Jain updated HIVE-12943:
--------------------------------
    Description: 
"USE Default" does not work with the latest hive 1.2.1
The message is 
"
   Cannot recognize input near 'default' '<EOF>' '<EOF>' in switch database statement;
line 1 pos 4
   NoViableAltException(81@[])
   at org.apache.hadoop.hive.ql.parse.HiveParser_IdentifiersParser.identifier(HiveParser_IdentifiersParser.java:11577)
   at org.apache.hadoop.hive.ql.parse.HiveParser.identifier(HiveParser.java:46055)
"

According to my analysis this may be due to the removal of "KW_DEFAULT" keyword from the grammar
of Hive parser according to the bug https://issues.apache.org/jira/browse/HIVE-6617


  was:
"USE Default" does not work with the latest hive 1.2.1
The message is 
"
   Cannot recognize input near 'default' '<EOF>' '<EOF>' in switch database statement;
line 1 pos 4
   NoViableAltException(81@[])
   at org.apache.hadoop.hive.ql.parse.HiveParser_IdentifiersParser.identifier(HiveParser_IdentifiersParser.java:11577)
   at org.apache.hadoop.hive.ql.parse.HiveParser.identifier(HiveParser.java:46055)
"

According to my analysis this may be due to the removal of "KW_DEFAULT" keyword from the grammar
of Hive parser according to the bug https://issues.apache.org/jira/browse/HIVE-6617

Adding the KW_DEFAULT keyword back to the HiveParser.g, HiveLexer.g and Identifier.g and It
worked. Wish to push it to apache-hive


> Use default doesnot work in Hive 1.2.1
> --------------------------------------
>
>                 Key: HIVE-12943
>                 URL: https://issues.apache.org/jira/browse/HIVE-12943
>             Project: Hive
>          Issue Type: Bug
>          Components: Database/Schema
>    Affects Versions: 1.2.1
>            Reporter: Kashish Jain
>             Fix For: 1.3.0, 1.2.1, 1.2.2
>
>
> "USE Default" does not work with the latest hive 1.2.1
> The message is 
> "
>    Cannot recognize input near 'default' '<EOF>' '<EOF>' in switch database
statement; line 1 pos 4
>    NoViableAltException(81@[])
>    at org.apache.hadoop.hive.ql.parse.HiveParser_IdentifiersParser.identifier(HiveParser_IdentifiersParser.java:11577)
>    at org.apache.hadoop.hive.ql.parse.HiveParser.identifier(HiveParser.java:46055)
> "
> According to my analysis this may be due to the removal of "KW_DEFAULT" keyword from
the grammar of Hive parser according to the bug https://issues.apache.org/jira/browse/HIVE-6617



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message