hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alan Gates (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HIVE-11378) Remove hadoop-1 support from master branch
Date Sat, 24 Oct 2015 03:52:27 GMT

     [ https://issues.apache.org/jira/browse/HIVE-11378?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alan Gates updated HIVE-11378:
------------------------------
    Attachment: HIVE-11378.5.patch

The TestHCatClient failures were not related, but the others were.  There were a couple of
places I'd forgotten to remove hadoop-1 references.  

I also had to make changes to ql/pom.xml to make the spark tests work.  IIUC, Hadoop brings
along javax.servlet.api version 2.5.  But because of ordering issues we were picking up version
3.0 from eclipse's version of jetty.  When I moved the hadoop dependencies out of the profile
that reversed the dependency order and we got 2.5 instead of 3.0, which broke the spark tests.
 I fixed that by having the hadoop clients exclude javax.servlet in their dependencies.  It
would be good if someone who understands maven well took a look at those changes.

> Remove hadoop-1 support from master branch
> ------------------------------------------
>
>                 Key: HIVE-11378
>                 URL: https://issues.apache.org/jira/browse/HIVE-11378
>             Project: Hive
>          Issue Type: Task
>          Components: Build Infrastructure
>    Affects Versions: 2.0.0
>            Reporter: Alan Gates
>            Assignee: Alan Gates
>             Fix For: 2.0.0
>
>         Attachments: HIVE-11378.2.patch, HIVE-11378.3.patch, HIVE-11378.4.patch, HIVE-11378.5.patch,
HIVE-11378.patch
>
>
> When we branched branch-1 one of the goals was the ability to remove hadoop1 support
from master.  I propose to do this softly at first by removing it from the poms removing the
20S implementation of the shims.  
> I am not going to remove the shim layer.  That would be much more disruptive.  Also,
I haven't done the homework to see if we could, as there may still be incompatibility issues
between various versions of hadoop2.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message