hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Venkata Srinivasa Rao Kolla (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-11651) Index creation is failing from beeline when execution engine is set to Tez
Date Wed, 26 Aug 2015 10:21:47 GMT

    [ https://issues.apache.org/jira/browse/HIVE-11651?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14712891#comment-14712891
] 

Venkata Srinivasa Rao Kolla  commented on HIVE-11651:
-----------------------------------------------------

I have tried this on Hive 0.13 version and Tez 0.4

> Index creation is failing from beeline when execution engine is set to Tez
> --------------------------------------------------------------------------
>
>                 Key: HIVE-11651
>                 URL: https://issues.apache.org/jira/browse/HIVE-11651
>             Project: Hive
>          Issue Type: Bug
>          Components: Beeline, Hive, Tez
>            Reporter: Venkata Srinivasa Rao Kolla 
>
> In Hive, with execution engine is set to Tez and when we tried to rebuild index on a
table (which is not empty) using beeline, index creation is not happening. It is not throwing
any error too on to console. But in the corresponding tez job logs we found below error:
> 2015-08-24 18:08:43,999 WARN [AMShutdownThread] org.apache.tez.dag.history.recovery.RecoveryService:
Error when closing summary stream org.apache.hadoop.ipc.RemoteException(org.apache.hadoop.hdfs.server.namenode.LeaseExpiredException):
No lease on /tmp/hive-alti-test-01/_tez_session_dir/573df26e-4a22-4bf5-ad5c-a0d72cdacec6/application_1439396922313_1732/recovery/1/application_1439396922313_1732.summary:
File does not exist. Holder DFSClient_NONMAPREDUCE_-117450461_1 does not have any open files.
at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.checkLease(FSNamesystem.java:2956)
at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.completeFileInternal(FSNamesystem.java:3027)
at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.completeFile(FSNamesystem.java:3007)
at org.apache.hadoop.hdfs.server.namenode.NameNodeRpcServer.complete(NameNodeRpcServer.java:641)
at org.apache.hadoop.hdfs.protocolPB.ClientNamenodeProtocolServerSideTranslatorPB.complete(ClientNamenodeProtocolServerSideTranslatorPB.java:484)
at org.apache.hadoop.hdfs.protocol.proto.ClientNamenodeProtocolProtos$ClientNamenodeProtocol$2.callBlockingMethod(ClientNamenodeProtocolProtos.java)
at org.apache.hadoop.ipc.ProtobufRpcEngine$Server$ProtoBufRpcInvoker.call(ProtobufRpcEngine.java:585)
at org.apache.hadoop.ipc.RPC$Server.call(RPC.java:928) at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:2013)
at org.apache.hadoop.ipc.Server$Handler$1.run(Server.java:2009) at java.security.AccessController.doPrivileged(Native
Method) at javax.security.auth.Subject.doAs(Subject.java:415) at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1556)
at org.apache.hadoop.ipc.Server$Handler.run(Server.java:2007)
> Below are the set of commands we have used: CREATE TABLE table02(column1 String, column2
string, column3 int, column4 string) ROW FORMAT DELIMITED FIELDS TERMINATED BY ','; LOAD DATA
LOCAL INPATH 'posts_us' OVERWRITE INTO TABLE table02; CREATE INDEX table02_index ON TABLE
table02 (column3) AS 'org.apache.hadoop.hive.ql.index.compact.CompactIndexHandler' WITH DEFERRED
REBUILD; ALTER INDEX table02_index ON table02 REBUILD;
> Does any one seen this problem?
> Regards, Srinivas.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message