hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rui Li (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HIVE-10999) Upgrade Spark dependency to 1.4 [Spark Branch]
Date Fri, 19 Jun 2015 11:39:00 GMT

     [ https://issues.apache.org/jira/browse/HIVE-10999?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rui Li updated HIVE-10999:
--------------------------
    Attachment: HIVE-10999.2-spark.patch

Talked about this with Chengxiang. We think the reason is that spark doesn't depends on {{jersey-servlet}}.
So during tests, we only add {{jersey-server}} to classpath, at version 1.14 (although I don't
know why maven doesn't get the 1.9 version, which is what spark really depends on). Then we
have the class not found error. There won't be a problem during runtime because we'll have
spark-assembly in classpath. That's why the qtests passed.

To solve the issue, we can either explicitly add the {{jersey-servlet}} dependency to failed
tests, or we can upgrade hive's jersey version to 1.9 and remove dependency on {{jersey-servlet}}
(it doesn't exist in 1.9).
Patch v2 takes the 1st approach which is simpler. But I think 2nd approach may be better,
if possible.

> Upgrade Spark dependency to 1.4 [Spark Branch]
> ----------------------------------------------
>
>                 Key: HIVE-10999
>                 URL: https://issues.apache.org/jira/browse/HIVE-10999
>             Project: Hive
>          Issue Type: Sub-task
>          Components: Spark
>            Reporter: Xuefu Zhang
>            Assignee: Rui Li
>         Attachments: HIVE-10999.1-spark.patch, HIVE-10999.2-spark.patch
>
>
> Spark 1.4.0 is release. Let's update the dependency version from 1.3.1 to 1.4.0.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message