hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fei Hui (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HIVE-16043) TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
Date Mon, 27 Feb 2017 04:33:45 GMT
Fei Hui created HIVE-16043:
------------------------------

             Summary: TezConfiguration.TEZ_QUEUE_NAME instead of tez.queue.name
                 Key: HIVE-16043
                 URL: https://issues.apache.org/jira/browse/HIVE-16043
             Project: Hive
          Issue Type: Bug
          Components: Tez
    Affects Versions: 2.2.0
            Reporter: Fei Hui


I see the following source in hive
{code:title=TezSessionPoolManager.java|borderStyle=solid}
   private TezSessionState getSession(HiveConf conf, boolean doOpen)
       throws Exception {
     String queueName = conf.get("tez.queue.name");
     ...
   }
  private TezSessionState getNewSessionState(HiveConf conf,
      String queueName, boolean doOpen) throws Exception {
    TezSessionPoolSession retTezSessionState = createAndInitSession(queueName, false);
    if (queueName != null) {
      conf.set(TezConfiguration.TEZ_QUEUE_NAME, queueName);
    }
  ...
  }
{code}
TezConfiguration.TEZ_QUEUE_NAME is the same as tez.queue.name , i think we should consistently
use it.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message