hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eugene Koifman <ekoif...@hortonworks.com>
Subject build bot on master
Date Fri, 28 Oct 2016 17:33:50 GMT
Hi,
all test runs are failing with the error below.   Does anyone know how to fix it?

Thanks,
Eugene

from https://builds.apache.org/view/H-L/view/Hive/job/PreCommit-HIVE-Build/1866/console




Build/hive/build/hive/testutils/ptest2/target/lib/guice-assistedinject-3.0.jar
[INFO] Copying velocity-1.7.jar to /home/jenkins/jenkins-slave/workspace/PreCommit-HIVE-Build/hive/build/hive/testutils/ptest2/target/lib/velocity-1.7.jar
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 10.833 s
[INFO] Finished at: 2016-10-28T15:57:26+00:00
[INFO] Final Memory: 29M/723M
[INFO] ------------------------------------------------------------------------
+ local 'PTEST_CLASSPATH=/home/jenkins/jenkins-slave/workspace/PreCommit-HIVE-Build/hive/build/hive/testutils/ptest2/target/hive-ptest-1.0-classes.jar:/home/jenkins/jenkins-slave/workspace/PreCommit-HIVE-Build/hive/build/hive/testutils/ptest2/target/lib/*'
+ java -cp '/home/jenkins/jenkins-slave/workspace/PreCommit-HIVE-Build/hive/build/hive/testutils/ptest2/target/hive-ptest-1.0-classes.jar:/home/jenkins/jenkins-slave/workspace/PreCommit-HIVE-Build/hive/build/hive/testutils/ptest2/target/lib/*'
org.apache.hive.ptest.api.client.PTestClient --command testStart --outputDir /home/jenkins/jenkins-slave/workspace/PreCommit-HIVE-Build/hive/build/hive/testutils/ptest2/target
--password '****' --testHandle PreCommit-HIVE-Build-1866 --endpoint http://104.198.109.242:8080/hive-ptest-1.0
--logsEndpoint http://104.198.109.242/logs/ --profile master-mr2 --patch https://issues.apache.org/jira/secure/attachment/12835837/HIVE-15093.1.patch
--jira HIVE-15093


Logs are located: http://104.198.109.242/logs/PreCommit-HIVE-Build-1866


Exception in thread "main" java.lang.RuntimeException: 404 Not Found
        at org.apache.hive.ptest.api.client.PTestClient.downloadTestResults(PTestClient.java:189)
        at org.apache.hive.ptest.api.client.PTestClient.testStart(PTestClient.java:137)
        at org.apache.hive.ptest.api.client.PTestClient.main(PTestClient.java:320)
+ ret=1
+ unpack_test_results
+ '[' -z /home/jenkins/jenkins-slave/workspace/PreCommit-HIVE-Build/hive/build ']'
+ cd /home/jenkins/jenkins-slave/workspace/PreCommit-HIVE-Build/hive/build/hive/testutils/ptest2/target
+ [[ -f test-results.tar.gz ]]
+ exit 1
+ rm -f /tmp/tmp.r59JTiDlN1
Build step 'Execute shell' marked build as failure
Recording test results
ERROR: Step ?Publish JUnit test result report? failed: Test reports were found but none of
them are new. Did tests run?
For example, /home/jenkins/jenkins-slave/workspace/PreCommit-HIVE-Build/hive/build/test-results/TEST-1-TestCliDriver-udf_upper.q-ctas_date.q-schema_evol_orc_acidvec_table_update.q-and-27-more-TEST-org.apache.hadoop.hive.cli.TestCliDriver.xml
is 2 days 19 hr old

[description-setter] Description set<http://stacktrace.jenkins-ci.org/search?query=[description-setter]%20Description%20set>:
HIVE-15093  /   master-mr2
Finished: FAILURE

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message