hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zoltan Haindrich <k...@rxd.hu>
Subject Re: Review Request 50768: HIVE-14415 Upgrade qtest execution framework to junit4 - TestPerfCliDriver
Date Thu, 04 Aug 2016 21:28:00 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/50768/#review144812
-----------------------------------------------------------




itests/qtest/src/test/java/org/apache/hadoop/hive/cli/AbstractCliConfig.java (lines 46 - 47)
<https://reviews.apache.org/r/50768/#comment210946>

    honestly: it might happen...but qtestgentask had it...so it might get used in the next
cli class...i would like to postone changes like this after all the vm files are removed -
this is almost the same logic as what qtestgentask uses internally...so comparing it might
be easier this way - after everythings good; think this whole getQueryFiles() will be deconstructed.



itests/qtest/src/test/java/org/apache/hadoop/hive/cli/AbstractCliConfig.java (line 113)
<https://reviews.apache.org/r/50768/#comment210933>

    honestly: it might happen...but qtestgentask had it...so it might get used in the next
cli class...i would like to postone changes like this after all the vm files are removed -
this is almost the same logic as what qtestgentask uses internally...so comparing it might
be easier this way - after everythings good; think this whole getQueryFiles() will be deconstructed.



itests/qtest/src/test/java/org/apache/hadoop/hive/cli/AbstractCliConfig.java (line 125)
<https://reviews.apache.org/r/50768/#comment210947>

    this will be changed later



itests/qtest/src/test/java/org/apache/hadoop/hive/cli/AbstractCliConfig.java (lines 128 -
135)
<https://reviews.apache.org/r/50768/#comment210942>

    sure, but later



itests/qtest/src/test/java/org/apache/hadoop/hive/cli/AbstractCliConfig.java (line 138)
<https://reviews.apache.org/r/50768/#comment210943>

    of course, and possibly use better ones.



itests/qtest/src/test/java/org/apache/hadoop/hive/cli/AbstractCliConfig.java (lines 150 -
164)
<https://reviews.apache.org/r/50768/#comment210945>

    i totally agree..i've seen it; but this have came from qtestgentask...i've removed a few
unnecessary things already



itests/qtest/src/test/java/org/apache/hadoop/hive/cli/AbstractCliConfig.java (line 170)
<https://reviews.apache.org/r/50768/#comment210921>

    i just wanted to keep the backward compatibility...the original qtesttask have passed
hadoop.version
    i'm not yet sure that this deep-dive-into-resources will work in every cases...just in
case it's needed later



itests/qtest/src/test/java/org/apache/hadoop/hive/cli/AbstractCliConfig.java (line 186)
<https://reviews.apache.org/r/50768/#comment210922>

    great idea! ;)



itests/util/src/main/java/org/apache/hadoop/hive/ql/QTestUtil.java (line 191)
<https://reviews.apache.org/r/50768/#comment210930>

    this static class initializer have caused some exceptions for me...i just wanted to get
rid of the load time problems...
    but yes! this it's not used anywhere else...=> private field initialized using constructor
    cool!



ql/src/test/templates/TestPerfCliDriver.vm (line 56)
<https://reviews.apache.org/r/50768/#comment210925>

    yeah...well I've just wanted to keep the 'original' clidriver manner intact as much as
possible ;)
    import static also works ;)



ql/src/test/templates/TestPerfCliDriver.vm (line 58)
<https://reviews.apache.org/r/50768/#comment210928>

    it's the testcase name; apparently its unused ;)



ql/src/test/templates/TestPerfCliDriver.vm (line 163)
<https://reviews.apache.org/r/50768/#comment210927>

    well..yes ;)


- Zoltan Haindrich


On Aug. 4, 2016, 9:25 p.m., Zoltan Haindrich wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/50768/
> -----------------------------------------------------------
> 
> (Updated Aug. 4, 2016, 9:25 p.m.)
> 
> 
> Review request for hive.
> 
> 
> Bugs: HIVE-14415
>     https://issues.apache.org/jira/browse/HIVE-14415
> 
> 
> Repository: hive-git
> 
> 
> Description
> -------
> 
> i'm using mostly the same code as QTestGenTask...I even made some of it's filter accessible
for now.
> 
> this patch also contains the upgrade of TestPerfCliDriver to junit4...which may make
it a bit less readable.
> 
> other changes:
> 
>  * HIVE_ROOT is detected by the existence of some specific directories
>  * hadoop_version is parsed from a jar instead of using some external property
> 
> 
> Diffs
> -----
> 
>   ant/src/org/apache/hadoop/hive/ant/QTestGenTask.java f372d7cb937d91c10d3dff0e4c51e0849c5e3c9b

>   itests/qtest/pom.xml 17968e69559a16a1971f6028ea3073ab693a6678 
>   itests/qtest/src/test/java/org/apache/hadoop/hive/cli/AbstractCliConfig.java PRE-CREATION

>   itests/qtest/src/test/java/org/apache/hadoop/hive/cli/TestPerfCliDriver.java PRE-CREATION

>   itests/util/src/main/java/org/apache/hadoop/hive/ql/QTestUtil.java b3cf6da56eddc5000515e5ebd34989e64b1c0010

>   ql/src/test/templates/TestPerfCliDriver.vm d2946cb4f9a7e3e9f8b3cc14a75802a483e7f95a

> 
> Diff: https://reviews.apache.org/r/50768/diff/
> 
> 
> Testing
> -------
> 
> i've already run it "alone" using maven - all the 60 cases have passed.
> 
> 
> Thanks,
> 
> Zoltan Haindrich
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message